Thumping and Hissing Noise from Speakers - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-28-2011, 12:42 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thumping and Hissing Noise from Speakers

I have a 2003 S500 4matic and I have been noticing a thumping and hissing noise coming from the speakers, which continues even when the ignition and all switches are turned off. This started as the sound system intermittently going off after a rainstorm. Now, the battery is completely drained to the point where the car does not start.

I've also noticed water leakage into the trunk, although all rubber seals appear to be intact.

Has anyone else experienced this and can give pointers how to remedy this?

Thank you.
danielbenznyc is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
help needed with thumping noise Rick Stone General Mercedes-Benz 1 02-19-2008 05:16 AM
speakers hissing supradupe Audio & Telematics Forum 2 04-17-2006 06:55 AM
*Thumping Noise* Vesnica W203 C-Class 2 01-30-2006 09:47 PM
Thumping noise... Guest (MBNZ) W124 E,CE,D,TD Class 4 12-25-2001 09:27 PM
"Random thumping" from rear speakers of C320. Guest (MBNZ) W203 C-Class 3 09-24-2001 07:33 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome