2002 e320 transmission slipping - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-15-2011, 07:08 AM Thread Starter
BenzWorld Junior Member
nowayjsk's Avatar
Date registered: Dec 2008
Vehicle: 2002 Mercedes E320
Location: Texas
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to nowayjsk
(Thread Starter)
2002 e320 transmission slipping

Hi, I have a 2002 e320 with a 4matic transmission. I have never had a problem with it until a week ago when I drove it about 50 miles in very hot weather. It was fine until I got off the interstate and came to a stop. The transmission would not engage. I turned it off and restarted a few minutes later. It ran until I had to stop again. I bought a transmission fluid dipstick and found out I was two quarts low. I added fluid but it still won't go into gear once engine heats up. Also the check engine light comes on the minute I hit the brakes. Anyone have any ideas. Your thoughts would be greatly appreciated.
nowayjsk is offline  
Sponsored Links
post #2 of 2 (permalink) Old 08-15-2011, 07:24 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
My first thought would be to post this on the W210 forum found in the sedans section. Also we have some sticky threads and there is a lot of transmission related info in there.

Chances are you have the well known leaking electrical connector and some ATF has wicked up into the TCU (transmission control unit). If you're lucky you can replace the plug and clean that thoroughly. Procedure is in those stickys.

Good luck and welcome to the forum.

Mercedes Benz - Das beste oder nichts!

Last edited by Musikmann; 08-15-2011 at 07:27 AM.
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2002 E320 4Matic - Transmission Gremlin? Bfamily General Mercedes-Benz 13 06-14-2011 01:51 AM
    2005 E320 CDI Transmission Slipping jkirsch General Mercedes-Benz 2 02-18-2011 08:43 AM
    Transmission Slipping in Cold Weather-'01 E320 95Rover W210 E-Class 18 01-26-2011 02:10 PM
    E320 CDI transmission slipping? kkau W211 E-Class 21 10-11-2010 09:44 PM
    transmission e320 2002 stationwagen robert henrickson General Mercedes-Benz 2 07-21-2010 08:50 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome