Hi - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-10-2011, 06:22 AM Thread Starter
BenzWorld Member
Date registered: Aug 2011
Vehicle: 1987 300D Turbo Powered by RO
Location: New Jersey
Posts: 283
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

Hi all,

I've been lurking on the this forum and some others trying to get info on the late 80's 300D turbo my grandfather has. He bought it new and has only put about 90k on it but is in need of some TLC. The biggest problem is that I live in NJ and he lives in Arkansas and i see him about once a year.

Problem 1 is the turbo not spooling up. Already received responses on things to check and will do so when I’m back out there.

Problem 2 is electrical. The car buzzes until you turn the directional on and then it stops. He seemed to have a local mechanic do some work on it, but I’m not sure if the buzzing is the cause of his work or has been there a while. He’s 94 and doesn’t hear so well, so it doesn’t really bother him. I believe it’s the flasher relay buzzing.

Problem 3 is engine vibration. I don’t recall the car vibrating at all but it does now. I would guess motor mounts would cure this.

Problem 4 is the AC which he’s not worried about as he only drives early morning. From what I have read on the forums, an r134 conversion might not be needed as there are R12 equivlants that can be used. Is this still the case?
zorecati is offline  
Sponsored Links
post #2 of 2 (permalink) Old 08-10-2011, 07:11 AM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,073
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome