Vito engine diagnostic indicator problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-07-2011, 11:45 AM Thread Starter
BenzWorld Newbie
Date registered: Aug 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Vito engine diagnostic indicator problem

Hi All............hope somebody can help.....I have a Vito 111 on a 55 plate, I have owned it from new and it has done 85000 fairly easy miles. It has been well maintained and has not given problems. The van has been great actually and is a pleasure to use.

However yesterday, when well laden (not over laden) the engine went into limp mode on a long hill and the diagnostic light came on.....I stopped and it reset.....the next big hill I had the same problem. Afterwards the van seamed to be quite down on power but ran OK.

Comming back today empty, the van started off still like it had a bit of a hangover, but after 30 miles or so seemed to clear and drove OK.

I need the van to be OK and take a decent load when needed.....before I ring Enza (my local MB)...........DOES ANYBODY HAVE ANY IDEAS?

enricogassolini is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2004 CLK270 cdi Tranmission problem with Engine diagnostic light mygaraj C209/A209 CLK-Class 20 01-05-2013 06:05 PM
    'Engine Diagnostic Indicator' and power loss at low revs. ian_cafe2u V-Class 9 06-05-2011 02:10 AM
    Engine Diagnostic Indicator lamp kotler W203 C-Class 3 12-30-2008 03:07 PM
    VITO Indicator hazards problem eey_ore_9 V-Class 0 04-03-2008 05:17 AM
    Engine Diagnostic Problem... help! bbuyuk R170 SLK-Class 5 05-11-2006 06:25 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome