Sluggish 83' 300SD - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-30-2011, 06:37 PM Thread Starter
BenzWorld Newbie
Date registered: Jul 2011
Vehicle: 1983 300SD Turbo 180k mi
Location: San Francisco
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Sluggish 83' 300SD

I just bought an 83' 300SD that was set up to run vegetable oil. I have had it reconfigured to only run DF now. The first time that it was sluggish we took it to the shop and they changed out all the filters. Then it happened again and we took it back to the same shop. The mechanic said that there was "sludge" in the filters so he thought that maybe there was "sludge" in the fuel tank as well, maybe from residue left behind from the vege? Anyway, He found a "clean" used tank from another 300SD that only used diesel fuel, so he switched out the tank and replaced the filters again. We thought that the problem was solved. However we got the car home yesterday and went out for a test drive today and again it is very sluggish, practically no power on hills, slowing down from 45 to 20. The pedel all the way to the floor, RPMs at 20. It almost feels like it needs to down shift. Is it possible that there is more sludge in the fuel system somewhere. Is there a fuel additive that I can use to clean out the fuel system? Any other suggestions?

Last edited by ksabrinaj; 07-30-2011 at 07:18 PM. Reason: needed to add more information
ksabrinaj is offline  
Sponsored Links
post #2 of 2 (permalink) Old 07-31-2011, 06:52 PM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,075
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    SLK 230 Sluggish aceangel R170 SLK-Class 9 04-13-2006 10:22 AM
    sluggish brake hakkaloong G-Class 9 01-25-2006 07:23 AM
    sluggish performance??? Dolphin27 R170 SLK-Class 4 01-01-2006 07:22 PM
    ML 320 a bit sluggish? laxman0324 W163 M-Class 9 11-26-2005 05:27 PM
    sluggish on take off! MANDERSON W126 S,SE,SEC,SEL,SD,SDL Class 3 06-17-2004 08:13 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome