ML350 AC stops cooling - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-24-2011, 03:31 PM Thread Starter
BenzWorld Newbie
Date registered: Jul 2011
Vehicle: 2005 ML350
Location: KY
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ML350 AC stops cooling

I have a 2005 ML350 with 108000 miles. The AC seems to have a mind of its own. I can set it on the coldest setting and it may cool for several hours just fine and suddenly it will feel like the temp. setting is being moved over to the hottest setting. Sometimes when I start the car it will not cool at all. Just depends on what mood its in. Usually we can get it to start cooling again by turning the ac on and off, or by changing the temp setting from coldest to hottest repeatedly or by holding the auto button until the temp resets. One method doesn't seem to work any better than another, it will just start blowing cold again until it changes its mind again. I've read several post on here about this problem. Not sure if its the blend door or the temp sensor or something else. I don't hear any clicking noise in the dash as described by some. It happens in both manual and auto setting. Nothing in particular seems to trigger the problem. I have had the refrigerant checked and that is ok. I would appreciate any help that anyone can give.
GinsML350 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 08-06-2012, 12:05 PM
BenzWorld Newbie
Date registered: May 2012
Vehicle: ML350 2007
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
got the same. issue seems to tend to happen in humid weather.
any suggestion? perhaps some AC climate sensor misbehavior
gublman is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Front left signal light works, then stops, then works, then stops...Bulb is fine... rabusalman W203 C-Class 6 03-23-2010 03:19 PM
    Cooling Cooling Fan does not come on as Temperature rises nichor R170 SLK-Class 1 08-16-2009 04:31 AM
    will nerf bars on a 2000 ml350 fit a 2004 ml350? busoptr W163 M-Class 0 01-02-2009 09:55 PM
    Wiper stops, radiator fan stops, indicators ok... Haku W202 C-Class 5 05-29-2008 04:30 AM
    Odometers Works, then Stops, then Works, then Stops......... dieselbenzfan123 W123 E,CE,D,CD,TD,TE Class 6 04-06-2008 07:47 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome