c200 spluttering when warm - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-20-2011, 02:38 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2011
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
c200 spluttering when warm

hi this is my first post so here goes my c200 auto starts fine but after the engines warmed up and say i come to some lights it starts spluttering and popping sounds like a tank once its started it stays. revs up slowly and very noisy and the engine shakes like like a sh*ttin dog. if i turn the car off and start again it runs like a dream for so long.

iv cleaned the maf and cant see any pipes disconnected or anything its starting to annoy me and been doing it for 2 weeks now any help would be brilliant its the first merc iv had and dont know much about them. cheers in advance
pep24 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Spluttering '98 C Class... Just.. General Mercedes-Benz 4 04-25-2009 05:25 AM
    1998 C200 Lack of Power when warm?? Jase W202 C-Class 7 03-10-2009 01:15 AM
    S420 spluttering, misfiring, brown exhaust, and HOT ychachad W140 S-Class 7 10-17-2004 08:59 AM
    Still missing and spluttering! 1994 E320 Limey W124 E,CE,D,TD Class 4 08-10-2004 04:02 AM
    500 SEC coughing and spluttering Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 4 10-30-2001 06:33 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome