car runs rough/hesitation when accelerating - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-20-2011, 07:08 AM Thread Starter
BenzWorld Newbie
Date registered: Jul 2011
Vehicle: 1990 300 CE
Location: NJ
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
car runs rough/hesitation when accelerating

My car will run rough most of the time. I tried fuel additives and spark plug change out with no results.

But it does not do this all the time. When it does run rough, it does so at idle and when accelerating. I'll step on the pedal and it will sputter and then all of a sudden it will take off like a bat out of hell. Weird.

You would think if it were an electrical or fuel problem it would be consistent in that it would always do this. But every now and then the car will run fine, no hesitation or rough running, but again, that is only a small amount of time that the good operation occurs.

Has anyone ever had this problem?

This has been going on for 2 years now. Took it to a gas station mechanic but they could not find the problem. Other than the fact that its annoying it allows me to drive it. Only stalled out once during the whole time.

Oh yes, one other thing,driving at speeds in excess of 50 mph (on the highway) not noticeable. But in city driving you can feel it hesitating up to 40 mph.
speechless is offline  
Sponsored Links
post #2 of 4 (permalink) Old 07-21-2011, 05:24 PM
BenzWorld Elite
Check Codes's Avatar
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Welcome aboard; there's a forum specific to your car and that is the W124 forum. That's probably a better place to search and post since this general one is about generic topics of general interest.

That said, you must be a very patient person. I couldn't live with that for two years, and I can guarantee I would have had the car into a good MB indie and not just some gas station mechanic.

Good luck.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #3 of 4 (permalink) Old 07-24-2011, 03:02 AM
BenzWorld Newbie
Date registered: Jul 2011
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)

my c200 is doing exactly the same. let me know how you get on please no one seems to have an answer for it
pep24 is offline  
post #4 of 4 (permalink) Old 07-29-2011, 09:38 AM
BenzWorld Junior Member
Date registered: Jan 2005
Vehicle: 1991 300CE, 1992 300CE, 1995 E320, 1998 E320
Location: Southeastern PA
Posts: 19
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
speechless, I suspect you need to replace the Oxygen sensor. That presumes the distributor cap, distributor rotor and ignition wires are in good condition. Oxygen sensor should be replaced every 60,000 miles.

Fred Hoelzle
Ferdman is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Stalling and hesitation while accelerating DUVAL320 W163 M-Class 8 09-08-2011 07:40 PM
    Hesitation while accelerating ?? xman W210 E-Class 19 11-24-2009 07:05 PM
    Hesitation when accelerating xman W210 E50 AMG, E55 AMG 7 09-01-2009 06:10 PM
    HESITATION WHEN ACCELERATING emiliet W126 S,SE,SEC,SEL,SD,SDL Class 2 04-03-2008 09:32 PM
    Hesitation above 3k RPM when accelerating polousa2000 W163 M-Class 6 02-22-2007 09:49 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome