1990 300CE RUNS ROUGH - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-17-2011, 10:39 AM Thread Starter
BenzWorld Newbie
Date registered: Jul 2011
Vehicle: 1990 300 CE
Location: NJ
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

My car will run rough most of the time. I tried fuel additives and spark plug change out with no results.

But it does not do this all the time. When it does run rough, it does so at idle and when accelerating. I'll step on the pedal and it will sputter and then all of a sudden it will take off like a bat out of hell. Weird.

You would think if it were an electrical or fuel problem it would be consistent in that it would always do this. But every now and then the car will run fine, no hesitation or rough running, but again, that is only a small amount of time that the good operation occurs.

Has anyone ever had this problem?

This has been going on for 2 years now. Took it to a gas station mechanic but they could not find the problem. Other than the fact that its annoying it allows me to drive it. Only stalled out once during the whole time.

Oh yes, one other thing,driving at speeds in excess of 50 mph (on the highway) not noticeable. But in city driving you can feel it hesitating up to 40 mph.
speechless is offline  
Sponsored Links
post #2 of 2 (permalink) Old 07-17-2011, 05:58 PM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,079
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld. Please complete your profile as this will help members give you the most accurate answer to your questions. Location is also important when we need to help you find parts etc. This forum is for introductions only and all questions should be posted on the appropriate sub forum for your car.

To edit your profile simply click on quick links “edit profile” (quick links is top Right of the page)

At the bottom of the page you will find forum jump, click on this and view all the available sub forums and there you will find the technical forum for your car.

For FAQ see the Benzworld help section here:
BenzWorld Help - Benzworld.org - Mercedes-Benz Discussion Forum
Benzworld help is for general enquires and all technical questions should be posted on the specific forum for your car. If you are not sure which forum it should be on then please ask me and I will give you a link.



"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1990 2.6 runs hot Stewarto7 W201 190-Class 4 04-06-2011 04:48 PM
    300sd runs rough gdstealth W126 S,SE,SEC,SEL,SD,SDL Class 12 07-12-2008 07:07 PM
    Runs rough Jippi W201 190-Class 0 10-25-2004 01:05 PM
    Runs rough when hot aeigou R/C107 SL/SLC Class 1 06-01-2004 06:28 PM
    Help Please! '87 560 SEL runs very rough arabak W126 S,SE,SEC,SEL,SD,SDL Class 6 06-05-2003 02:56 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome