1994 Mercedes s420 runs rough Need help - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-08-2011, 10:13 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1994 Mercedes s420 runs rough Need help

I have a 1994 s420, it runs rough with no lights on in the instrument cluster. No codes are in the cars current or history as of last scan. I have replaced the engine wiring harness, replaced the wiring on the throttle body, all of the wires were bare. I just put on new cap and rotors with no luck. It runs at idle but has no acceleration. The asr light is not on. It runs smooth for a few seconds then feels like it starts to load up. Im out of ideas and dont know what else to do. So if you have any ideas let me know
thank you
thekookoothe is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Mercedes S420 Runs bad! thekookoothe General Mercedes-Benz 8 12-15-2014 08:02 PM
    Mercedes S420 Runs bad! thekookoothe General Mercedes-Benz 1 02-08-2011 06:40 PM
    1994 Mercedes e320 No reverse but But runs &shifts great in drive mers320 W124 E,CE,D,TD Class 1 07-11-2009 10:08 PM
    1994 Mercedes S420 Excellent MGySgt. Anders For Sale/Wanted/Trade/Giveaway 0 06-25-2009 12:54 AM
    1994 E420 problems, stalls and runs real rough RudyH13 W124 E,CE,D,TD Class 1 04-02-2008 08:21 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome