83' 300 TD Air Compressor Disaster - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-02-2011, 09:08 PM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2011
Vehicle: 1983 300TD
Location: Los Angeles
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
83' 300 TD Air Compressor Disaster

Hi Everyone,

So on the heels of my first post and resolution of a glow plug issue I was driving my new wagon down the freeway with my AC on when WHAM! SLAP! BANG! A loud noise, hissing, screeching and all other kinds of chaos made me think I was in for real trouble...

I pulled off the freeway and after testing by driving up and down the street, listening, starting/stopping, and looking, I found the cause. My AC Compressor, the front most part of it, burst or broke or failed, but in any case now has a two or three inch popsicle stick sized piece of metal sticking off of it with an empty screw hole at it's end. As I drive it pivots and occasionally comes in contact with the fan. Additionally, on the front most part of the unit, behind a triangular steel plate, a circular steel plate is floating around loose, making a lurching noise. It really sounds terrible.

I only drove the car as far as needed to get it somewhere safe...now the thing is, there's a series of bolts around the front ring of the AC unit which I believe will allow me to pull out the broken parts if I loosen them. My plan is to do so in the morning so I can drive the car without that awful racket until I can fix or replace the unit, but I honestly don't know anything about these units, and don't want to damage anything...I don't care that if it works at the moment, just want to get back on the road ASAP...any thoughts? Thanks...
Vincent D is offline  
Sponsored Links
post #2 of 3 (permalink) Old 07-02-2011, 09:30 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,531
Mentioned: 9 Post(s)
Quoted: 1070 Post(s)
Sounds like the center clutch bolt come off. Not such rare as you could expect. Make sure you didn't loose other parts in the process. You are lucky on older model you can take AC belt of and keep on driving. With serpentine belt it is impossible. Get new bolt and torque it per recommendations. Most likely thread locker will be involved.
Kajtek1 is online now  
post #3 of 3 (permalink) Old 07-02-2011, 10:42 PM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2011
Vehicle: 1983 300TD
Location: Los Angeles
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Wow Kajtek1, thanks for the quick response and info...will take belt off in the morning, glad I don't have to start messing with the unit...for now...
Vincent D is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    ANyone know how to replace compressor clutch on OM617 while compressor still attached to loss W123 E,CE,D,CD,TD,TE Class 16 06-22-2010 09:26 PM
    DIY Disaster B15M General Mercedes-Benz 27 02-21-2008 08:22 PM
    $15 5-in-1 air compressor for those that bought used SLKs with missing compressor Black98SLK230 R170 SLK-Class 2 11-29-2004 03:20 PM
    OMG... disaster... eastsidebenz W124 E,CE,D,TD Class 15 03-02-2004 11:05 AM
    S 600 disaster Guest (MBNZ) W140 S-Class 7 09-11-2002 08:20 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome