Odometer/Mileometer not working - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-20-2011, 01:14 PM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2011
Vehicle: 1978 500SLC
Location: Málaga Spain
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to wendirjd
(Thread Starter)
Unhappy Odometer/Mileometer not working

Hi there from the South of Spain!
Went for the Spanish ITV (MOT equivalent) this morning and, first time I've seen this done here - they wrote down the mileage! Unfortunately, it didn't pass because of a too-loose left-hand bearing on the central steering shaft underneath (sorry, not sure how it translates into English) and because both front indicator lenses have slight breaks in them and I'd taped them over for now. The first one I understand is a necessity as I can feel it when braking but the lights?!?! Give me a break! Anyway, my problem's the odometer/mileometer, as it's been stuck on 165+K for the last three years and I've left it like that to avoid the hassle and expense of getting yet something else fixed. However, when I get what needs fixing to go back and pass I'll have to go through the whole thing again and they're not going to like it when they see NO mileage from the last reading! Can someone tell me if I can repair this myself or ask a somewhat mechanically-minded friend to do it? Does it mean dismounting the whole instrument panel (guess that's a kind of 'duh' question)? Would appreciate some input as love this old classic, even though it's cost a fortune over the last few years in parts etc. - the engine's a gem! Don't know if it comes up here but it's a silver 1978 500SLC (and needs some cosmetic TLC unfortunately but we're going through a really bad economic crisis here for that right now!)

Last edited by wendirjd; 06-20-2011 at 01:15 PM. Reason: typo
wendirjd is offline  
Sponsored Links
post #2 of 3 (permalink) Old 06-20-2011, 07:51 PM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,081
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #3 of 3 (permalink) Old 06-21-2011, 12:01 AM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2011
Vehicle: 1978 500SLC
Location: Málaga Spain
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to wendirjd
(Thread Starter)
Muchas gracias!
wendirjd is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Mileometer Reading Query Steve M Black General Mercedes-Benz 3 07-16-2010 03:18 PM
    Trans Fluid leak near odometer connector, odometer stopped working and ASR light on. 92 500 Saunderklaus W140 S-Class 6 06-08-2010 03:16 PM
    Odometer and Trip Odometer not working houston14 R129 SL-Class 1 05-27-2008 04:39 PM
    Speedmeter working but odometer not working 300SE W126 S,SE,SEC,SEL,SD,SDL Class 2 05-23-2006 07:45 AM
    Odometer/trip odometer stopped working theratpatrol R/C107 SL/SLC Class 8 07-23-2005 08:12 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome