Picking up 1994 E420 1st time MB owner - Page 3 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 26 (permalink) Old 06-30-2011, 08:40 PM
BenzWorld Junior Member
 
V8MERC124's Avatar
 
Date registered: Feb 2010
Vehicle: 1993 400E 115k mi currently and 2007 E63 AMG White on Tan
Location: Manteca California (Central Valley)
Posts: 49
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
hmm...interesting the sticker is saying baltimore. You should look into getting a VMI through a dealership or maybe a certified mechanic. I dont know how much it will cost (if it does cost anything), because I got it done through my dads friend. The good thing about it is that its better than a carfax and you will know all of the history.
For your bulb, does it come on with the other lights when you start it and then it goes away? If it does then it should be fine. If not, then you may wanna get in there and replace it.

2007 Mercedes-Benz E63 AMG 60k mi. White on Tan

1993 Mercedes-Benz 400E purchased June 2009 with 69K mi *original miles* (now 115k in 2014)
V8MERC124 is offline  
Sponsored Links
Advertisement
 
post #22 of 26 (permalink) Old 07-01-2011, 12:40 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1994 Mercedes Benz E420
Location: Denver, Colorado
Posts: 100
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to kbr1972
(Thread Starter)
No, the light doesn't come on at all, even when you first put the key in, so I assume the bulb is blown...BUT, I'm not throwing any codes so it shouldn't be on. As far as the car itself is concerned, it's had a rough life, but it's in good hands now.
kbr1972 is offline  
post #23 of 26 (permalink) Old 07-05-2011, 01:24 AM
BenzWorld Newbie
 
Date registered: Jun 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Post issues with my 1994 e420.

hello, i am also new to this forum and i have a 1994 e420 136k milles i will post pics soon...i am having a electrical issue. one of my fuse is always blowing out. its the one that powers up the radio and cigarette lighter. can anyone help out with an electrical diagram that can help me find the short in my system?

thank you.
baymuscle454 is offline  
post #24 of 26 (permalink) Old 07-05-2011, 03:30 PM
BenzWorld Junior Member
 
V8MERC124's Avatar
 
Date registered: Feb 2010
Vehicle: 1993 400E 115k mi currently and 2007 E63 AMG White on Tan
Location: Manteca California (Central Valley)
Posts: 49
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
baymuscle454
Did you try google searching? I believe there is a website or a forum member that has w124 service manuals on discs that have been posted to a website. These discs should have a wiring diagram on them. (the discs have been uploaded to a website so you dont have to buy them) I dont know of the site or person but I will browse for them a bit later.

2007 Mercedes-Benz E63 AMG 60k mi. White on Tan

1993 Mercedes-Benz 400E purchased June 2009 with 69K mi *original miles* (now 115k in 2014)
V8MERC124 is offline  
post #25 of 26 (permalink) Old 07-05-2011, 04:36 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1994 Mercedes Benz E420
Location: Denver, Colorado
Posts: 100
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to kbr1972
(Thread Starter)
Quote:
Originally Posted by baymuscle454 View Post
hello, i am also new to this forum and i have a 1994 e420 136k milles i will post pics soon...i am having a electrical issue. one of my fuse is always blowing out. its the one that powers up the radio and cigarette lighter. can anyone help out with an electrical diagram that can help me find the short in my system?

thank you.
Nice hi-jack, you couldn't start and ask your question in your own thread? Anyway, happy to report that I took the Benz through inspection and it passed with flying colors. As well, I had thought I was having electrical issues or air pump related issues since the head rests in the rear didn't fall down. It turns out that the rear sunshade which doesn't go up or down anymore wasn't seated all the way down. From what I read the sunshade needs to be fully retracted for the rear headrests to work. So I pushed the headrest all the way down and took some scotch tape and now the sunshade won't become unseated...problem solved....tragedy averted
kbr1972 is offline  
post #26 of 26 (permalink) Old 07-05-2011, 07:24 PM
BenzWorld Junior Member
 
V8MERC124's Avatar
 
Date registered: Feb 2010
Vehicle: 1993 400E 115k mi currently and 2007 E63 AMG White on Tan
Location: Manteca California (Central Valley)
Posts: 49
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
tragedy averted
Good to hear that!
Quote:
Nice hi-jack, you couldn't start and ask your question in your own thread?
He has a point! and before you post your question on your OWN thread, do some research. Chances are that some one has already delt with your situation, there is a whole community of w124 owners not just you. Just a few kind words thats all!

2007 Mercedes-Benz E63 AMG 60k mi. White on Tan

1993 Mercedes-Benz 400E purchased June 2009 with 69K mi *original miles* (now 115k in 2014)
V8MERC124 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1st Time MBZ Owner! 1994 SL500! Have a question! Planet13 General Mercedes-Benz 0 05-07-2010 09:00 AM
    1 owner 80K 1994 E420 - what's it worth? benzroman W124 E,CE,D,TD Class 7 06-04-2009 06:00 PM
    Long time '97 E420 owner - 145K Tskip33 General Mercedes-Benz 0 10-22-2008 10:16 AM
    1st TIME Mercedes-Benz owner! ISO Advice (1994 E320) TMaticE320 W124 E,CE,D,TD Class 12 04-28-2006 08:41 AM
    Buying an E420 - first time MB owner Colorado E420 W124 E,CE,D,TD Class 7 12-21-2004 04:47 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome