87 300E Hard to start Any Ideas? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-15-2011, 06:39 AM Thread Starter
BenzWorld Newbie
Date registered: May 2011
Vehicle: 87 Mercedes Benz 300E
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
87 300E Hard to start Any Ideas?

i have a 1987 300e its a great car but it has some annoying issue that can be solved if you know exactly what is wrong with it. Anyways, the car starts perfectly when it has been sitting for a while and the engine is cold, but then when i use the car and turn it off to go do something when i come back and try to restart it it doesnt fire. The engine starter is cranking the engine but the engine itself doesnt fire and there is no sign that it is trying to fire. When that happens what i do is: i wait at least 10-15 minutes and try to crank the engine again and the engine fires up like if nothing had happened. Some people have told me that it's a fuel problem, but i dont buy it. the reason is while im driving it the engine doesnt stall, i checked the injectors and they are spraying fuel, and i checked the spark plugs with a light tester and they have power. I read on another forum and somebody mentioned the crankshaft position sensor im not sure if that is it but i believe there are 2 of them. one in front of the engine next to the crankshaft pulley, and the other on the rear part of the engine on the bell housing. If anyone can give me an idea of what this problem may be and the solution i would really appreciate it. also if the crankshaft position sensor is the problem i would really appreciate if someone would post a picture of the location. THANK YOU
Scarfaze is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    '92 300e 2.6 hard start chohyundae General Mercedes-Benz 4 02-15-2010 05:33 AM
    87 300e hard start cxcaro W124 E,CE,D,TD Class 3 08-15-2009 01:30 PM
    Hard first start on 300e mg_w124 W124 E,CE,D,TD Class 7 07-31-2007 12:17 PM
    86 300E hard start THEROG W124 E,CE,D,TD Class 1 03-07-2007 04:05 AM
    1987 W124 300E hard to start hot or cold Any ideas. rcs hawaii W124 E,CE,D,TD Class 1 12-15-2004 07:31 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome