BlueEfficiency fuel injectors failed again? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-14-2011, 01:19 PM Thread Starter
BenzWorld Newbie
Date registered: Jan 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
BlueEfficiency fuel injectors failed again?

Hi All,

I'm not a regular user of this form, in fact the last time I used it was when my fuel injectors failed on my 2009 C250 cdi last year. These were replaced with the new type and all sorted...or so I thought.
On Saturday the exact same thing happened again - the car went into limp home mode and now they've diagnosed fuel injector problems again.

Has anyone with the new type of injectors had this problem again? The car is less than 18 months old and I'm getting worried about the resale value!

gt79 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1997 S500 No Fuel at Injectors (fuel pumps already replaced) dleroux W140 S-Class 11 03-24-2012 03:46 AM
    Fuel System Service Procedure - Fuel Distro, Lines and Injectors BenzHacker R/C107 SL/SLC Class 10 03-29-2010 04:36 AM
    Jumped fuel relay gets fuel to injectors!Still not starting! Distributor Plunger? salthepal W124 E,CE,D,TD Class 2 10-08-2008 03:24 PM
    bad fuel? problem with fuel injectors? tmpleton88 W203 C-Class 5 08-08-2007 04:26 PM
    280E: Fuel to Cold Start Injector, but not to main injectors - Fuel Press. Regulator? or other?? GermanCarNut W123 E,CE,D,CD,TD,TE Class 0 01-25-2004 03:12 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome