1989 300TE revival. - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-10-2011, 08:55 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2011
Vehicle: 1989 300TE
Location: Baltimore, MD
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1989 300TE revival.

Hey yall,
I just acquired an 89 300TE that had been sitting for ~7yrs. I replaced the fuel pump because the old one was all corroded and rusted solid and also drained all the old browned up gas. I later got a 5 gal gas can, filled it with 93 octane gas, seafoam gas treatment and 104+ octane booster and it started right up. Since the motor is still good, I decided to go ahead with the project.

Looking forward to a rewarding experience on here.
mbcurious is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-10-2011, 06:26 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,197
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Bad cam- 1989 300te. AlanS W124 E,CE,D,TD Class 14 11-22-2013 01:06 PM
    1989 300TE getlost4x4 W124 E,CE,D,TD Class 15 08-25-2010 02:38 PM
    1989 300te... new cam needed. ? AlanS W124 E,CE,D,TD Class 10 05-20-2010 04:53 AM
    no SLS on my 1989 300TE Ned Kelly W124 E,CE,D,TD Class 4 04-26-2010 01:32 AM
    1989 300TE getalex General Mercedes-Benz 0 05-20-2009 07:03 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome