New Member here- Toronto - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-06-2011, 01:41 PM Thread Starter
BenzWorld Newbie
 
e5hundo's Avatar
 
Date registered: Aug 2010
Vehicle: 2003 E500
Location: Toronto
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New Member here- Toronto

Hey everyone, i'm Andrew, new to the forum and new to Merc ownership...bought my first benz late last year, its a black on black 2003 E500...got it with 76,000km's and its around 96,000 at the moment..not 4matic...i was surprised how good it was in the winter with some nice Michellin winters..

So far so good with the car, the only issues i've had has been the heat exchanger valve, which got stuck and i was being blasted with A/C when trying to use the heat back in early March when it was still hovering around the minus degrees!..$60 from benz and a well done tutorial from this site and me and a buddy took care of it..The only other problem has been what my mechanic said was a seized or slightly seized bearing on the control arm...its got a bit of an annoying sound to it so far...if anyone has any experience with that issue let me know what the $$$ was like to remedy it...

Other than that things are going good!
e5hundo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-06-2011, 08:55 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,616
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #3 of 3 (permalink) Old 06-14-2011, 01:54 PM Thread Starter
BenzWorld Newbie
 
e5hundo's Avatar
 
Date registered: Aug 2010
Vehicle: 2003 E500
Location: Toronto
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Good to be hear =)
e5hundo is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
New member - Canada, Toronto Strider-g3 General Mercedes-Benz 1 04-12-2011 01:27 AM
New member in Toronto BobRBob General Mercedes-Benz 2 09-18-2009 10:58 AM
New member from Toronto Greek 560SL General Mercedes-Benz 3 08-08-2009 02:00 PM
New member from Toronto pcymui General Mercedes-Benz 1 10-03-2008 05:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome