Broke down in Centralia Washington - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-31-2011, 04:30 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2011
Vehicle: 1990 Mercedes 190E
Location: Walla Walla, Washington
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Broke down in Centralia Washington

1990 Mercedes 190E with 120,000 miles. After driving 800 miles over the weekend on the way back to Walla Walla, WA...wiper slowed, car turned off and wouldn't start...just a click click sound. Took it to a mechanics shop. After jump starting the car they tested the battery and the alternator and didn't see anything wrong with them. Drove the car away and in ten minutes it did the same thing. Not it is back at the shop. Not sure what is wrong. Any ideas?
greendragonfly is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-31-2011, 08:27 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,164
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #3 of 3 (permalink) Old 06-01-2011, 08:27 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2011
Vehicle: 1990 Mercedes 190E
Location: Walla Walla, Washington
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Any ideas?

The shop now says it is the alternator, replaced it and thinks it is ready to go. We will be driving 5 1/2 hours back to the shop to pick the car up and hope that is what the problem was. I am not sure how come the shop first told us they'd checked it and thought there wasn't a problem with it. I hope we don't get to trying to drive it home and have it break down again. Anything else we should consider testing on the car before trying to drive it again?
greendragonfly is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    DC, Washington 94Wagenmeister U.S. - East 71 11-24-2015 07:08 PM
    Hello from Washington DC railrazer General Mercedes-Benz 0 01-16-2009 09:22 PM
    Welcome to Washington D.C. Qubes Off-Topic 9 09-06-2007 07:46 AM
    Washington DC AMPM R170 SLK-Class 2 09-22-2003 05:30 AM
    OT: Washington DC Tangent R170 SLK-Class 6 09-05-2003 11:07 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome