blown fuss - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-19-2011, 02:04 PM Thread Starter
BenzWorld Newbie
Date registered: May 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question blown fuss

replaced alt wire hit ex pipe blow fuse can not find fuse for alt can any body help me out 2000 s500

Last edited by rdeautomotive; 05-19-2011 at 02:06 PM. Reason: no car info
rdeautomotive is offline  
Sponsored Links
post #2 of 5 (permalink) Old 05-19-2011, 05:46 PM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
You have a W220, try asking in that forum. Hint: Look in the sedans section.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 5 (permalink) Old 05-23-2011, 09:05 AM Thread Starter
BenzWorld Newbie
Date registered: May 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
look in sedans did not find fuse for charging sys
rdeautomotive is offline  
post #4 of 5 (permalink) Old 05-23-2011, 01:21 PM
BenzWorld Elite
Date registered: May 2005
Vehicle: '07 GL320CDI
Location: Albuquerque
Posts: 5,070
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
There's no such thing as a "fuse for the charging system."

Look for burned-up wiring to alternator.

Kent Christensen
'07 GL320CDI
lkchris is offline  
post #5 of 5 (permalink) Old 05-26-2011, 07:31 PM
BenzWorld Member
Date registered: Apr 2009
Vehicle: 1999 E300TD
Location: PA
Posts: 167
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
if i remember there is a "fuse" for the charging system. under the passenger side front carpet there is a junction block that has some internal fuses...50 amp or 100 amp...not sure but they are large...block has to be replaced as a unit..easy job to do just make sure battery is disconnected
saleen1276 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Fuss keeps blowing don terpening W201 190-Class 1 02-23-2009 12:37 PM
    glowplug blown... nikedunk W126 S,SE,SEC,SEL,SD,SDL Class 1 12-20-2006 05:58 PM
    Help - possible blown gasket sergiuvlad W210 E-Class 6 12-13-2006 08:39 PM
    1) Extra "no cleaning fuss" tax to ALL silver Mb owners and how does the Darkmann W163 M-Class 0 08-14-2002 08:37 PM
    2.6 Blown!!!! Guest (MBNZ) W201 190-Class 3 06-05-2002 11:14 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome