1980 300TD accelerator linkage - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-19-2011, 01:43 AM Thread Starter
BenzWorld Junior Member
Date registered: Dec 2010
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1980 300TD accelerator linkage

I was driving my wagon last night and after stopping at a light I could no longer accelerate. The gas pedal is no longer connected to the mechanism under the hood. I'm not sure what part I need or how to attach it. One arm is definitely loose and I'm not sure what/how it attaches to. Another part that is disconnected I assume is the cruise control which doesn't work (nor do I want it to). Any ideas on what piece I need? Or websites/diagrams that may help?
Attached Thumbnails
Click image for larger version

Name:	PICT2777.jpg
Views:	139
Size:	70.8 KB
ID:	376045   Click image for larger version

Name:	PICT2778.jpg
Views:	115
Size:	76.9 KB
ID:	376046   Click image for larger version

Name:	PICT2788.jpg
Views:	225
Size:	87.1 KB
ID:	376047  
Attached Images
darkbloom52 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 05-19-2011, 10:37 AM
BenzWorld Elite
SaleenS7's Avatar
Date registered: Apr 2005
Location: SC
Posts: 1,764
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Welcome to the benzworld,

Try posting this in the W123 section of the forum. You'll have other people who own similar cars there who can probably give you a hand. Good luck!

W123 E,CE,D,CD,TD,TE Class - Benzworld.org - Mercedes-Benz Discussion Forum
SaleenS7 is offline  
post #3 of 3 (permalink) Old 05-19-2011, 11:31 PM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,065
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    94 S600 Accelerator control linkage dapower1 W140 S-Class 9 02-02-2011 02:12 PM
    accelerator linkage question panzerbenzer W201 190-Class 6 05-11-2009 07:23 PM
    Accelerator linkage problem....... ReBell W163 M-Class 4 09-13-2008 10:12 AM
    Accelerator linkage sticking - 300SD barry_s_u W126 S,SE,SEC,SEL,SD,SDL Class 3 01-14-2004 08:53 PM
    HELP! Stuffed-up accelerator/throttle linkage..... Jules W126 S,SE,SEC,SEL,SD,SDL Class 0 10-19-2002 06:42 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome