2002 CL600 ABC Pump - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-18-2011, 05:00 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 2002 CL600 ABC Pump

I have a used 2002 CL600 that has 70k miles on it. I took it into the shop because there was oil on my garage floor. They told me it needed a new line and a hydraulic block. OK I paid for that took it home and the front left corner of the car started squeaking. I looked at the floor and more hydraulic oil on the floor. I took it back in they said the oil must have belched out the top of the tank and no problem but I need a new a arm and ball joints. OK I agreed to by that. They just called and said the ball joint and arm was in but my ABC pump would not recharge and my car was sitting on the tires and could not be moved and I need a new ABC pump. More thousands of dollars. They said when they put it on the lift the pump discharged and when they put it back on the ground and tried to charge it up it would not take a charge.

What is going on? Somebody help me understand. I have put 100 miles on this beautiful car in the last six months and have had it in the shop the rest of the time giving away $1,000 bills.
yokeltl is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-18-2011, 05:16 PM
BenzWorld Elite
 
mbvis's Avatar
 
Date registered: Jan 2010
Vehicle: 99 E430, 01 E430 Sport, 00 SL500
Location: LA, CA
Posts: 3,266
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
I think they broke your car.
You "drove" the car back to the shop with the squeaking problem. Now the car can not be "moved".
Tell them to put it back the way it was when you "drove" it back the their shop the second time so you can "drive" it to the dealer to get it "fixed".
Document the mileages, symtoms, times, dates, ... Prepare to take them to small claim court.
mbvis is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2002 CL500 ABC Pump replacement alexgreggs C215 CL-Class 5 06-02-2015 06:44 PM
    ABC/PS pump leaking causing ABC suspension severe drop 2003 s600 W220 S-Class 16 07-03-2012 04:54 PM
    2002 S55 ABC pump/fluid - help bzliteyear The Discount Tire Direct Tire, Wheel, Brake & Suspension 0 05-18-2009 04:17 PM
    CL600 2003 W215 ABC pump sergeym5 C215 CL-Class 1 12-21-2007 01:17 PM
    CL600 issues/ ABC and NAV Brilliant Silver C215 CL-Class 13 04-17-2007 08:07 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome