electrical???? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-14-2011, 08:58 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
electrical????

I have a 1995 S420 with the notoriously bad engine wiring harness. I have had a rough idle and poor acceleration for a short time. I had the fuel filter replaced and new plugs. This did not fix the problem...then 4 days later, the car ran like a dream. It ran well for about 4 weeks and then back to the rough idle and poor acceleration. Now my right blinker is on a fast blink, but when the bulbs were replaced, it did not correct the problem. The hazards blink at the proper pace. I do not think it is the module that controls the blinkers and hazards and rear defrost, etc. Any ideas?? Can the problems be related? BTW...my ASR light stays on...
deanaf9 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-14-2011, 09:57 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Dean, you are probably better off posting in the W140 section. Just scroll down from here until you see sedans, W140 section. Good luck and welcome to the forum.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Help -- Electrical!!! blindeman W210 E-Class 44 12-07-2010 02:11 PM
electrical 90 w126 420 se W126 S,SE,SEC,SEL,SD,SDL Class 6 10-16-2008 01:43 AM
Electrical Juanello Audio & Telematics Forum 2 01-23-2008 11:12 PM
Electrical Help ....again BOB703 W124 E,CE,D,TD Class 5 10-01-2007 09:59 AM
Electrical HELP Rob B W123 E,CE,D,CD,TD,TE Class 0 11-12-2006 06:30 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome