CLK 430 ECU Failure HELP!!!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-13-2011, 05:09 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2011
Vehicle: Carlsson CLK430
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
CLK 430 ECU Failure HELP!!!!

I have been having an intermittent fault with my ECU and having the fault codes cleared by either MB or a specialist sorted it out.
However now it has totally failed and even MB cannot clear the fault codes. HELP!!!!!
Nico61 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-13-2011, 05:17 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 290 Post(s)
Quote:
Originally Posted by Nico61 View Post
I have been having an intermittent fault with my ECU and having the fault codes cleared by either MB or a specialist sorted it out.
However now it has totally failed and even MB cannot clear the fault codes. HELP!!!!!
How do you think we can help? What year car do you have and what is your location, your profile tells us nothing. And what were the fault codes? Information does help you know.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #3 of 7 (permalink) Old 05-17-2011, 06:34 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2011
Vehicle: Carlsson CLK430
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Sorry!!

Sorry Eric. I am in the UK, the car is a 2000 model year CLK430. I am getting a whole load of error messages on the dashboard,from the BAS,ESP etc to coolant low,oil low (they arent btw) and the car will only operate in "limp mode". That is it will only go into first gear and reverse. I have been told that second hand components will not work and that I must have them coded for my car??

What Im looking for is any help and advice that can get me a reasonably inexpensive resolution. It looks like I will need to replace pretty much everything and that might be uneconomic.
Nico61 is offline  
post #4 of 7 (permalink) Old 05-17-2011, 06:43 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 290 Post(s)
Quote:
Originally Posted by Nico61 View Post
Sorry Eric. I am in the UK, the car is a 2000 model year CLK430. I am getting a whole load of error messages on the dashboard,from the BAS,ESP etc to coolant low,oil low (they arent btw) and the car will only operate in "limp mode". That is it will only go into first gear and reverse. I have been told that second hand components will not work and that I must have them coded for my car??

What Im looking for is any help and advice that can get me a reasonably inexpensive resolution. It looks like I will need to replace pretty much everything and that might be uneconomic.
The first thing to do is check your battery and have it tested and also the charging circuit, this is the very basic. Low power on a Merc will set so many fault codes that you would not believe. These are not like run of the mill cars. And is the battery is ok and the charging circuit is OK the what fault codes were you getting? I mean fault codes and not simply warning lights.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #5 of 7 (permalink) Old 05-19-2011, 09:23 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2011
Vehicle: Carlsson CLK430
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Eric,thats been done and the battery is fine. Good comment tho because the specialist who looked at it tested the battery firs.
The fault codes are, BAS,ESP,ASP. Both a gearbox specialist with generic equipment and an MB dealer have tried to clear down the codes and failed. This always worked in the past when I would not get a code on the dash,but when the car went into limp mode they would see an intermittent speed sensor fault on their machines.

My previous symptoms were that the car would stop changing gear (mostly when I was decelerating it would stop at 4th gear and then not change) and then would reset it self if I turned the car off and on. This would continue intermittently for a couple of months and then would not reset,then I would have to got to a specialist who would clear out the codes and the cycle would start again. At no time has the gearbox mechanically let me down,it changes crisply and when its going it really is am amazing thing.
Nico61 is offline  
post #6 of 7 (permalink) Old 05-19-2011, 09:33 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2011
Vehicle: Carlsson CLK430
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Eric,I hope you get the felling that I love my car!! I bought it when my finances were better and I want to keep it going.

It really is a special thing,its ten years old and still turns heads. I have had some really special cars in the past,including a BMW M5,Range Rover,Jaguars etc and nothing has had the impact that this does.

It goes like a sledge hammer,sounds like only a Benz V8 does and,I adore it. LOL
Nico61 is offline  
post #7 of 7 (permalink) Old 05-19-2011, 11:11 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 290 Post(s)
You have to be more specific with the fault codes.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Emissions failure, NEW ECU?? thetransporter W220 S-Class 9 04-07-2012 10:37 AM
    CLK 430 ECU reset nickclk C208/A208 CLK-Class 0 07-01-2010 05:41 PM
    ECU Failure.. Merc600sec W140 S-Class 12 10-31-2009 02:57 AM
    99 clk 430 brake lamp failure bab2020 C208/A208 CLK-Class 1 04-08-2006 03:01 PM
    ECU failure Pringles W124 E,CE,D,TD Class 2 01-30-2004 01:01 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome