1994 S320 Climate control fuse problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-10-2011, 07:11 PM Thread Starter
BenzWorld Newbie
Date registered: May 2011
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1994 S320 Climate control fuse problem

This is my first post here and I am fairly new to this. I have a 1994 S320 with a climate control fuse (#18) that keeps blowing. Initially it seemed to blow with the AC on or intermittently, but after checking a few components and disconnecting the aux heater motors and radiator fans etc, it now blows with the engine running. I have checked the wiring diagrams and the grey/red wire that goes to the aux motors, switching unit, pneumatic control unit etc, seems to be shorted to ground or something that is connected to it is shorting it. I have disconnected the auxiliary pumps, blower reg., radiator fans, fan relay, aux pump relay, internal air temp switch, pneumatic control unit (though I don't see a grey/red wire going to it). Anyone have an idea what is causing the grey/red wires to go to ground, or is there a common short location for this problem? I am going to get the service manual for the W140 tomorrow and have a look at the wiring diagrams there and start tracing the wires. I appreciate any help on this matter - I am not crazy about taking apart stuff looking for a short
Ray32825 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Heat Stuck on, Climate Control Panel/Climate Control Servo Problem? 123Doug W123 E,CE,D,CD,TD,TE Class 25 05-06-2016 11:40 PM
    1994 SL AC climate Control Panel problem...please help s132008 R129 SL-Class 3 11-24-2009 06:35 AM
    1995 S320 Climate Control problem jcberean W140 S-Class 5 09-24-2009 08:31 AM
    s320 climate control albert100 W140 S-Class 5 05-09-2009 07:07 AM
    Where is the Ovp fuse on a S320 1994 S3201994 W140 S-Class 1 09-26-2007 12:58 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome