Start error - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 05-06-2011, 02:12 AM Thread Starter
BenzWorld Junior Member
 
Nime's Avatar
 
Date registered: Jan 2009
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Start error

1998 W168 A160 Petrol A Class 160.000 Km

I recently changed the key fob -plastic case only-. Remote lock functions properly. However I couldn't start the car. It did crank a second then now no sound engine when I try to start again. Battery is low but headlights are ok.

The electronic circuit seems not so complex, just a few simple chips. Why it's too expensive I don't know. I have no 2nd. key.

I repeat again there is no crank no sound when I tried. A guy from garage came and examined by hand/eye, tried to start then towed. I wasn't there.

I did no damage to transponder, just replaced the fob. Strange. Now I want to ask that if the key is malfunctioned, can diagnostic inform us?
Nime is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 05-06-2011, 07:35 AM
BenzWorld Senior Member
 
Andrzejek's Avatar
 
Date registered: Jul 2004
Vehicle: 00 C-230, 04 C-240
Location: Lancaster, CA
Posts: 468
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
The key FOB works on radio Frequency (RF) and InfraRed (IR). Both, RF and IR lock/unlock the car. But, the ignition only works with IR. I have had a problem with my key FOB where the lock/unlock worked fine, but the IR did not for starting the car (weak battery, dirty IR window on key and ignition).

Swap the batteries in the key FOB. Also clean the small, red windows on the tip of the key and the ignition switch on the dash.

If the key FOB is still not working, order a new one from Mercedes.

Replacing the ignition circuit is your last resort.
Andrzejek is offline  
post #3 of 18 (permalink) Old 05-06-2011, 10:42 AM Thread Starter
BenzWorld Junior Member
 
Nime's Avatar
 
Date registered: Jan 2009
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I'm not sure this key has infrared. I think spare key has no battery, if no battery then no infrared. According to Lofty, even key with empty batteries, engine will start, because of rfid.

I noticed there is a white plastic piece inside the original fob which one couldn't fit Chinese remake, so I throw it. I don't know it's purpose, maybe it's a useful thing when blade is opened.
Nime is offline  
post #4 of 18 (permalink) Old 05-06-2011, 11:10 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,768
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
The big circuit board inside the key is for locks and alarm only.
Ignition chip is about 2mm diameter mounted in the tip of the key.
I understand that you replaced lock remote into new case, but the ignition chip is still in the old one?
Now it would be a good time to buy spare key.
Kajtek1 is online now  
post #5 of 18 (permalink) Old 05-06-2011, 01:51 PM Thread Starter
BenzWorld Junior Member
 
Nime's Avatar
 
Date registered: Jan 2009
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
OMG, that plastic piece would be RFID?

Edit: OK, this is the RFID which I did throw

Last edited by Nime; 05-06-2011 at 02:17 PM.
Nime is offline  
post #6 of 18 (permalink) Old 05-06-2011, 02:14 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,768
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
Can you post a picture of old open case?
Kajtek1 is online now  
post #7 of 18 (permalink) Old 05-06-2011, 02:18 PM Thread Starter
BenzWorld Junior Member
 
Nime's Avatar
 
Date registered: Jan 2009
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I'm gonna buy most expensive rfid in history...
Nime is offline  
post #8 of 18 (permalink) Old 05-06-2011, 04:29 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,768
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
You have some reddish stuff covering something in right lower corner. I believe this is the chip.
Kajtek1 is online now  
post #9 of 18 (permalink) Old 05-09-2011, 05:16 AM Thread Starter
BenzWorld Junior Member
 
Nime's Avatar
 
Date registered: Jan 2009
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Nice. Dealer asked me 325€ and 15 days for a key.
Nime is offline  
post #10 of 18 (permalink) Old 05-10-2011, 01:07 AM Thread Starter
BenzWorld Junior Member
 
Nime's Avatar
 
Date registered: Jan 2009
Posts: 31
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Nime is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    start error bonta V-Class 42 08-12-2011 07:43 AM
    Start error Mk85 General Mercedes-Benz 2 11-16-2007 06:25 AM
    Start Error !!!! timer W168 A-Class 2 12-28-2006 02:53 PM
    Start Error drkonek W163 M-Class 6 10-01-2006 10:19 PM
    Start Error Hugo R170 SLK-Class 0 11-10-2002 04:26 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome