'88 420SEL No Power in Gear - Perfect in Neutral - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-27-2011, 11:45 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2011
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post '88 420SEL No Power in Gear - Perfect in Neutral

I have a 420SEL 1988 that has run great for me for two years. All of a sudden, it just lost all power and couldn't even climb a 2% grade to get out of a gas station. It runs great in neutral, revs great in neutral, but put it in gear and it feels like when you step on the gas nothing happens, no acceleration, no revving, nothing. Crawls along at 10mph and can be coaxed up to 25mph but pushing on accelerator does nothing.

One other big clue - my mechanic says it runs great first thing in the morning when engine is cold for about two minutes then problems return.

He has replaced fuel pump, fuel filter, fuel distributor and checked lots of things on car with no luck.

Any ideas? I would greatly appreciate your help because car has been in shop for three months now with three different mechanics and no progress.


Thanks,
At Wits End,
John
johntalbs is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-27-2011, 11:47 AM
BenzWorld Elite
 
1984babybenz's Avatar
 
Date registered: Nov 2009
Vehicle: 1984 190D 2.2
Location: Silver Spring, MD
Posts: 2,458
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Try posting in your cars specific forum. You will get more answers faster there.
W126 S,SE,SEC,SEL,SD,SDL Class - Benzworld.org - Mercedes-Benz Discussion Forum



1979 Pontiac Firebird 5.7- 86,142 miles
1981 Chevrolet Corvette 5.7
1984 Mercedes 190D 2.2 Auto - 140,628 miles
1987 Chevrolet Sprint 1.0 - 139,000 miles
1989 Oldsmobile Cutlass Calais S - 123,000 miles
1989 Chrysler New Yorker - 95,000 miles
1991 Dodge Stealth R/T - 101,000 miles
1999 Dodge Durango - 178,000 miles
2003 Dodge Dakota - 203,000 miles
1984babybenz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    one owner 420sel, no rust, perfect interior roadrosen For Sale/Wanted/Trade/Giveaway 0 03-01-2011 07:45 PM
    Bypass Neutral Safety Switch 420sel MarkyBluntz W126 S,SE,SEC,SEL,SD,SDL Class 4 02-02-2011 06:14 PM
    ML320 Slips out of gear into neutral MISSMARVELOUS General Mercedes-Benz 3 08-20-2010 08:16 AM
    Rough Idle in gear and neutral jlougster W210 E-Class 6 06-27-2007 10:54 AM
    Coasting in Neutral Gear? MBSLRwannaBE R171 SLK-Class 37 05-26-2007 01:45 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome