7 Speed Transmission Question/Problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-20-2011, 07:51 PM Thread Starter
BenzWorld Member
Date registered: Jan 2011
Vehicle: 1991 300D 2.5 Turbo 263k, 1993 300D 2.5 Turbo 280k, 2007 GL320CDI 4Matic 100k, 2007 E320 Bluetec 65k
Posts: 133
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
7 Speed Transmission Question/Problem

I have a 2007 GL320 CDI and a 1991 300D. Ever since day 1, the GL has a weird characteristic the 91 does not. In the 300D, when letting off the accelerator at about 25-45, the transmission goes into a 'neutral' mode and idles. The GL however, does not do this. When the accelerator is let off, it just holds the gear and pretty much loses velocity because the gear is still hooked up. This can get annoying at times and I just wanted to know if this is a normal feature of the 7spd or if I have to do something to it to fix it. Thanks.
STPilots5150 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 04-21-2011, 09:29 AM
BenzWorld Member
millpond's Avatar
Date registered: May 2010
Vehicle: 2007 SL 550, 50th Anniversary Edition
Location: Astoria, Oregon, USA
Posts: 267
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
This is how my 7 speed works too. Perfectly normal.
millpond is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    722.9 7-speed transmission problem. zhuorongdeng General Mercedes-Benz 86 12-25-2014 09:47 PM
    Transmission Problem? 99 SLK 230 5 speed Rgroat R170 SLK-Class 6 08-10-2012 05:37 PM
    190e 5 speed manual transmission problem 190EEEE W201 190-Class 5 04-09-2009 07:13 PM
    Problem with 7 speed transmission in 2005 500e wassguy W211 E-Class 3 07-21-2007 09:24 AM
    7 speed transmission, problem wassguy General Mercedes-Benz 1 07-18-2007 11:51 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome