2000 ML320 Issues - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-06-2011, 04:58 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2000 ML320 Issues

Hey everyone!
Great forum!
I just inherited a 2000 ML320 (basic) and have some questions. I realize I could just go to a mechanic or dealership but if I can get some answers here it could save me some time and/or money. Thanks!

First of all, the keyless remote doesnt work. I plan on getting new batteries tomorrow but the guy that I got the car from said it never worked. What are my options if batteries are not the issue? Where and what do you recommend I buy a new set? OR does this model not work with keyless entry?

Second, the fuel gage is alittle messed up. When I start the car, it shows its empty and as I drive it slowly creeps back up. Kind of annoying to worry about how much gas is left.

Last problem is the radio reception. FM works fine, but AM barely works. Oddly, when I have my phone charging, AM doesnt work at all.....?

That's it for now, hope some of you Benz junkies can help me out!
Thanks!
AjML320 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-06-2011, 05:18 PM
BenzWorld Elite
 
1984babybenz's Avatar
 
Date registered: Nov 2009
Vehicle: 1984 190D 2.2
Location: Silver Spring, MD
Posts: 2,458
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Take a look at your cars forum, you are more likely to get more specific answers there.
W163 M-Class - Benzworld.org - Mercedes-Benz Discussion Forum



1979 Pontiac Firebird 5.7- 86,142 miles
1981 Chevrolet Corvette 5.7
1984 Mercedes 190D 2.2 Auto - 140,628 miles
1987 Chevrolet Sprint 1.0 - 139,000 miles
1989 Oldsmobile Cutlass Calais S - 123,000 miles
1989 Chrysler New Yorker - 95,000 miles
1991 Dodge Stealth R/T - 101,000 miles
1999 Dodge Durango - 178,000 miles
2003 Dodge Dakota - 203,000 miles
1984babybenz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    ML320 Issues, Need Help stevhuff W163 M-Class 12 06-06-2010 12:35 PM
    Serious 02 ML320 issues... yankeess W163 M-Class 4 04-30-2010 08:12 AM
    Kenwood DNX-7120 with BackUp Cam (CCD-2000) Self Installed in ML320 2000 danielali W163 M-Class 12 03-22-2010 03:45 PM
    02 ML320 ESP issues iLoveMyHonda W163 M-Class 4 07-05-2009 09:12 PM
    "01 ML320 issues with A/C CaliBNZ W163 M-Class 14 08-27-2002 05:07 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome