2010 C300 from Dallas - Audio Question - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-04-2011, 04:02 PM Thread Starter
BenzWorld Junior Member
 
Jay Perry's Avatar
 
Date registered: Apr 2011
Vehicle: 2010 Mercedes Benz C300 Sport
Location: Dallas, TX
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2010 C300 from Dallas - Audio Question

Just got my 2010 C300 Sport and need to know how to hook up my aftermarket sub amp, Kenwood mono class D, and JL W6v2 in my new ride. I've always used after market head units so this is new territory for me. Non Harmon Kardon factory system.
Jay Perry is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-04-2011, 06:14 PM
BenzWorld Elite
 
1984babybenz's Avatar
 
Date registered: Nov 2009
Vehicle: 1984 190D 2.2
Location: Silver Spring, MD
Posts: 2,458
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Try looking in the audio forum.
Audio & Telematics Forum - Benzworld.org - Mercedes-Benz Discussion Forum



1979 Pontiac Firebird 5.7- 86,142 miles
1981 Chevrolet Corvette 5.7
1984 Mercedes 190D 2.2 Auto - 140,628 miles
1987 Chevrolet Sprint 1.0 - 139,000 miles
1989 Oldsmobile Cutlass Calais S - 123,000 miles
1989 Chrysler New Yorker - 95,000 miles
1991 Dodge Stealth R/T - 101,000 miles
1999 Dodge Durango - 178,000 miles
2003 Dodge Dakota - 203,000 miles
1984babybenz is offline  
post #3 of 3 (permalink) Old 04-04-2011, 06:52 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,590
Mentioned: 3 Post(s)
Quoted: 311 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2010 C300 Navigation rroggy Audio & Telematics Forum 0 11-05-2010 08:30 AM
My new 2010 C300 dewydang W204 C-Class 0 09-07-2010 01:38 AM
2010 C300 Iphone question jacobsed W204 C-Class 2 06-21-2010 09:05 AM
Cars and Coffee - Dallas, TX 2/6/2010 vSID Events 0 01-31-2010 05:26 PM
New C300 - Audio question GBMB300 Audio & Telematics Forum 3 03-27-2009 04:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome