W204 Comand System Display Blackout - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 03-28-2011, 09:39 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
W204 Comand System Display Blackout

Hello, my 2009 W204 Comands Display goes blank then sometimes goes back to normal then goes blank again. Any ideas on why this happens.
ricjac8888 is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 03-29-2011, 08:40 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Probably a short, use your warranty. I had a similar issue but mine was because I added a CD changer and didn't have the car coded to add it to the D2B loop.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 18 (permalink) Old 04-12-2011, 04:21 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the info, my big problem is this car of mine was imported from the US. The local dealer here is asking for a $10,000.00 enrollment to cover warranty which is absurd.
ricjac8888 is offline  
post #4 of 18 (permalink) Old 08-25-2011, 10:48 AM
BenzWorld Junior Member
 
Date registered: Jun 2011
Vehicle: W204 320cdi 2007
Location: Sweden
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi
I have the problem with W204 2008, the lcd display start to turn OFF and after
10 sec turn ON, every last 3 days
what can be problem?
markus74 is offline  
post #5 of 18 (permalink) Old 08-26-2011, 04:05 PM
BenzWorld Junior Member
 
Date registered: Aug 2011
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Command display

The command display has an internal short and needs to be replaced. It is about a 15 minute job. As for the 10k enrollment cost, where did you import the vehicle to? The warranty rep at the dealership should be able to register the vehicle at no cost at all. The 10k is probably to perform the work and then ensure that the dealer is getting paid before the warranty is registered. Once the warranty validity of the vehicel is confirmed ie: the vehilce was not branded as a salvage title in another country the dealer and yourself would recoupe those funds.
Benztech0919 is offline  
post #6 of 18 (permalink) Old 08-28-2011, 01:15 AM
BenzWorld Junior Member
 
Date registered: Jun 2011
Vehicle: W204 320cdi 2007
Location: Sweden
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Benztech0919 View Post
The command display has an internal short and needs to be replaced. It is about a 15 minute job. As for the 10k enrollment cost, where did you import the vehicle to? The warranty rep at the dealership should be able to register the vehicle at no cost at all. The 10k is probably to perform the work and then ensure that the dealer is getting paid before the warranty is registered. Once the warranty validity of the vehicel is confirmed ie: the vehilce was not branded as a salvage title in another country the dealer and yourself would recoupe those funds.
Hi, if I understand you well, the problem is Display? or cable?

The car is from Germany, but I live in Sweden...and now when this problem start with Display ,I was in Serbia, becouse I am on holyday there

what is 10k?

Regards
Markus

markus74@hotmail.com
Autoprog.se Vi utför mätarjusteringar, chiptuning samt felsökningar!
markus74 is offline  
post #7 of 18 (permalink) Old 08-28-2011, 02:11 AM
BenzWorld Member
 
Terry_Tibbs's Avatar
 
Date registered: Jul 2011
Vehicle: 2004 W220 S320CDI
Location: Derbyshire UK
Posts: 115
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by markus74 View Post
Hi, if I understand you well, the problem is Display? or cable?

The car is from Germany, but I live in Sweden...and now when this problem start with Display ,I was in Serbia, becouse I am on holyday there

what is 10k?

Regards
Markus

markus74@hotmail.com
Autoprog.se Vi utför mätarjusteringar, chiptuning samt felsökningar!
Its not cool to hijack someone's thread

XFactor: Where the bewildered are wheeled out to be sniggered at by multi millionaires.

Gone:
2005 Range Rover Vogue
Terry_Tibbs is offline  
post #8 of 18 (permalink) Old 08-29-2011, 05:18 AM
BenzWorld Junior Member
 
Date registered: Jun 2011
Vehicle: W204 320cdi 2007
Location: Sweden
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Terry_Tibbs View Post
Its not cool to hijack someone's thread
Hi
How you mean?
I need help about this problem
why I must make new Thread, when it will be same?

can you help me with this problem?

Regards
Milan
markus74 is offline  
post #9 of 18 (permalink) Old 01-02-2012, 03:12 PM
BenzWorld Junior Member
 
Date registered: Jul 2010
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
If the comand screen is going blank it means
The LCD screen is shorted you will need to buy a new unit or repair
The current one which is difficult as the entire unit has to be stripped down
To take the LCD screen out the motorised unit
m.mir01 is offline  
post #10 of 18 (permalink) Old 02-27-2012, 03:30 PM
BenzWorld Junior Member
 
Date registered: Feb 2012
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
New to forum..my LCD screen is blank..I think it's a short circuit in the screen..taken the screen out the car..where is the internal short..how do i take the motor off the screen?? Help
Sully123 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    W204 COMAND APS install koutamagic Audio & Telematics Forum 0 01-27-2011 03:59 AM
    Help comand W204 gerolamo Audio & Telematics Forum 0 08-13-2010 03:58 AM
    Removing audio 20 display w204? India021007 Audio & Telematics Forum 2 05-29-2010 01:31 PM
    Pinout for W211 and W204 Comand 2.5? shimmers Audio & Telematics Forum 7 04-05-2010 10:41 PM
    W204 COMAND PROBLEM.....HELP PLEASE muccapazza W204 C-Class 1 07-23-2009 05:56 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome