Engine temp thermostat faulty - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-23-2011, 04:42 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: vito 108 cdi
Location: Darlington uk
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Red face Engine temp thermostat faulty

hi all.

ive got a mercedes vito all but an old one. seem to have a problem with the temp on gauge reading a maximum of 57 degrees c when fully warmed up, meaning the van is running with a cold engine.

i have checked temp in the expansion tank which is the same as
gauge which leads me to believe that the ENGINE TEMP THERMOSTAT IS FAULTY.

could this affect other parts of the engine such as fuel economy (overfuelling)or odd smells coming from rear of engine (off side).

which are not injectors as all have been done 2 new & 2 reseated

it seems to be non stop with this machine at the moment but maybe ill get there!!!

any help would be fantastic.
GREASED MONK is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-24-2011, 05:18 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,608
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #3 of 3 (permalink) Old 03-24-2011, 10:33 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: vito 108 cdi
Location: Darlington uk
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
Welcome to Benzworld
Hi Eric hows it going.

Bobby.
GREASED MONK is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Faulty thermostat? Charliedavies10 R/C107 SL/SLC Class 8 08-28-2010 07:15 PM
Engine operating temp. 100 degrees C.. Clutch fan or thermostat? hilarushi W163 M-Class 2 07-14-2010 05:45 AM
Faulty temp gauge FoolishCarriage W124 E,CE,D,TD Class 3 11-30-2009 04:36 PM
faulty temp gauge Richard Booth W123 E,CE,D,CD,TD,TE Class 0 08-12-2009 06:40 PM
Faulty outside temp gauge Iwan W203 C-Class 2 11-01-2003 10:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome