97 S500 Blower motor help - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-12-2011, 02:21 AM Thread Starter
BenzWorld Newbie
Date registered: Mar 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
97 S500 Blower motor help

Hey guys, I have a 97 S500 with no blowing air. I tested the relay and it's good, so I took the motor out and got a new one, but now I need to get the impeller blades off. How can I do this? The old motor shaft is pretty well rusted and is incredibly hard to turn. I've let it soak in liquid wrench for a day now, but still nothing. Tried a hammer to tap it loose, and I tried to drill through the center of the shaft, but ti's hardened steel. Any ideas?
Waveripper308 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-12-2011, 10:01 AM
BenzWorld Senior Member
chuckindetroit's Avatar
Date registered: Jun 2003
Vehicle: 1986 560SEL, 1986 560SEL, 1992 500SEL, 1999 S500
Location: Motown 313
Posts: 470
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
First, you should ask this question in the W140 section, which is your car. You need to set the squirel cage up on something to get the motor off the ground and use a hammer and drift to knock the shaft out.
chuckindetroit is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Blower not working but blower motor fine what to check next? classicchic W123 E,CE,D,CD,TD,TE Class 20 05-07-2014 05:56 PM
    1998 W210 E300DT Bad Blower Regulator or Blower Motor?? How to tell DieselNuts W210 E-Class 12 08-16-2012 09:32 AM
    Blower Motor + Burning Smell = No Blower Motor nuts2that W210 E-Class 6 07-28-2010 01:07 AM
    1996 S500 blower motor relay JPool W140 S-Class 6 08-06-2009 07:41 PM
    where can I get an ac blower motor for my 1995 s500 ?? RUTV S500 W140 S-Class 12 09-03-2008 08:59 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome