1999 SL500 Heater/AC blower issue - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-11-2011, 11:22 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2010
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1999 SL500 Heater/AC blower issue

Folks,
I just picked up a 1999 SL500 and it's got a strange issue. I can turn the Heater or A/C on(whichever is needed) and either will run for about 15-20 minutes. After that, air flow stops coming out the vents, but you can still hear the blower and you can still see the display showing that the blower is running. I can turn the blower up and down and hear it going up and down

Any hints or ideas on this one?

txfooter
txfooter is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1999 SL500 Blower Motor issue txfooter General Mercedes-Benz 1 01-13-2012 09:24 PM
Heater Blower Issue stevewilson123 W140 S-Class 2 03-09-2011 09:33 PM
clk 230 Heater Blower problem / Lower suspension issue krisskarma C208/A208 CLK-Class 1 02-19-2010 04:16 PM
Heater issue - possible Blower dieselbenzfan123 W123 E,CE,D,CD,TD,TE Class 3 02-16-2008 01:55 PM
Heater Blower issue Pops2000 W123 E,CE,D,CD,TD,TE Class 2 01-13-2008 07:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome