My seat squeaks and is driving me mad! Help - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-07-2011, 07:15 AM Thread Starter
BenzWorld Elite
 
Tri-Star's Avatar
 
Date registered: Aug 2007
Vehicle: C320 4matic
Location: Charlotte, NC
Posts: 1,743
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation My seat squeaks and is driving me mad! Help

Recently I noticed that my car's driver seat squeaks as it moves into driving position upon putting the key into the ignition. Can someone please help or have experienced this and resolved it?

Tri-Star is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-07-2011, 11:28 AM
BenzWorld Elite
 
mbvis's Avatar
 
Date registered: Jan 2010
Vehicle: 99 E430, 01 E430 Sport, 00 SL500
Location: LA, CA
Posts: 3,266
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
1. Locate the squeaky source with
Mechanic's Stethoscope
2. Lubricate/oil/grease/...
mbvis is offline  
post #3 of 6 (permalink) Old 03-07-2011, 11:59 AM
BenzWorld Elite
 
1984babybenz's Avatar
 
Date registered: Nov 2009
Vehicle: 1984 190D 2.2
Location: Silver Spring, MD
Posts: 2,458
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Probably one of the bearings. As stated before, find the source and put grease on the track.
1984babybenz is offline  
post #4 of 6 (permalink) Old 03-08-2011, 07:14 AM Thread Starter
BenzWorld Elite
 
Tri-Star's Avatar
 
Date registered: Aug 2007
Vehicle: C320 4matic
Location: Charlotte, NC
Posts: 1,743
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I'm hoping to spray the tracks with WD-40, would this suffice?

Tri-Star is offline  
post #5 of 6 (permalink) Old 03-08-2011, 09:41 AM
BenzWorld Elite
 
1984babybenz's Avatar
 
Date registered: Nov 2009
Vehicle: 1984 190D 2.2
Location: Silver Spring, MD
Posts: 2,458
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
WD-40 would work to take away the squeak, but it's not a long term lubricant.
After spraying it with WD-40, use white lithium grease or the like to keep it working smoothly.
1984babybenz is offline  
post #6 of 6 (permalink) Old 03-10-2011, 11:10 AM Thread Starter
BenzWorld Elite
 
Tri-Star's Avatar
 
Date registered: Aug 2007
Vehicle: C320 4matic
Location: Charlotte, NC
Posts: 1,743
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by 1984babybenz View Post
WD-40 would work to take away the squeak, but it's not a long term lubricant.
After spraying it with WD-40, use white lithium grease or the like to keep it working smoothly.
thanks for your response, i'll give it a try this weekend.

Tri-Star is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Exhaust Problem (driving me mad) Watto W901-905 Sprinter 1 12-05-2009 08:27 PM
    Another Airmatic Question - Driving me Mad! ukguy W220 S-Class 5 11-23-2009 12:17 AM
    Exhaust Problem (driving me mad) Watto W901-905 Sprinter 0 08-13-2009 09:18 AM
    HELP!!!! 16v driving me mad tinny W201 190-Class 1 08-14-2006 04:06 PM
    Driving me mad!!! chrisg W126 S,SE,SEC,SEL,SD,SDL Class 4 12-08-2004 03:10 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome