coolant*leak* - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-02-2011, 03:24 PM Thread Starter
BenzWorld Member
 
jballem's Avatar
 
Date registered: Mar 2011
Vehicle: 1978 450 SLC, 1993 S600, 1995 300E 4matic, 1992 190E 2.3, 1987 190E 2.3-16, 2010 Landrover Discovery
Location: Drexel hills, Penn.
Posts: 386
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post coolant leak

Hello i am new here but anyway, i have a 1992 190e 2.3 and there is a pool of coolant on my skid plate (which you have to remove to gain access to the oil pan) i know my Head gasket is not blown and the car runs beautifully but i cant see Where it seems to be coming from i can see the small puddle of it through the exhaust pipes coming off the engine (left side) i am not Sure what it could be i would think it is one Of the hoses if there Is any under there But i would appreciate any one's help as i am in distress. Also the fluid Is green i would think that it is coolant.



Thanks,
James

Last edited by jballem; 03-02-2011 at 04:21 PM.
jballem is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-02-2011, 05:54 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Welcome aboard. Please click user cp and add your vehicle and location to your profile, it's useful information going forward.

The new member area is really just a place to introduce yourself and say Hi. The specific car forums is where tech information is freely available. Cruise down the main page to the W201 forum in the sedan section and post in there.

That said, no one here can tell you for sure where your leak is coming from based on what you've said. If you're not qualified to pull the covers and track it down, take it in and have it diagnosed, it could be lots of different things, from a hose to a water pump or anything in between...but guesses won't help you much. You are correct, though, that color is coolant and you definitely want to get it fixed. Check the level (cold engine) to make sure you're not running it low.

Good luck.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #3 of 7 (permalink) Old 03-02-2011, 06:16 PM Thread Starter
BenzWorld Member
 
jballem's Avatar
 
Date registered: Mar 2011
Vehicle: 1978 450 SLC, 1993 S600, 1995 300E 4matic, 1992 190E 2.3, 1987 190E 2.3-16, 2010 Landrover Discovery
Location: Drexel hills, Penn.
Posts: 386
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Would you know if there are any coolant related hoses running down under or near the bottom of the engine? i would only hope it is a clamp or hose that is loose, I am qualified to pull the covers and take a look but it has been cold lately i will try and do it as the days get warmer thank you for you're quick response and welcoming me here.

Thanks,
James

Last edited by jballem; 03-02-2011 at 06:20 PM.
jballem is offline  
post #4 of 7 (permalink) Old 03-02-2011, 06:21 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
None I know of. You have radiator hoses up front and heater hoses at the firewall, plus a few other places. But looking at a puddle is not how you find a leak. The leak could be quite a ways away, dripping onto something and then running to the low point before falling to the pan. As I say, you need to pull the pans and get in, under and around it and find the source. Puddles don't help much.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #5 of 7 (permalink) Old 03-02-2011, 06:29 PM Thread Starter
BenzWorld Member
 
jballem's Avatar
 
Date registered: Mar 2011
Vehicle: 1978 450 SLC, 1993 S600, 1995 300E 4matic, 1992 190E 2.3, 1987 190E 2.3-16, 2010 Landrover Discovery
Location: Drexel hills, Penn.
Posts: 386
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Okay well again thank you for repyling so quickly. i will pull the plate off and take a look in there and try to see what is going on.

Thanks,
James
jballem is offline  
post #6 of 7 (permalink) Old 03-02-2011, 06:40 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,176
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #7 of 7 (permalink) Old 03-03-2011, 03:03 PM Thread Starter
BenzWorld Member
 
jballem's Avatar
 
Date registered: Mar 2011
Vehicle: 1978 450 SLC, 1993 S600, 1995 300E 4matic, 1992 190E 2.3, 1987 190E 2.3-16, 2010 Landrover Discovery
Location: Drexel hills, Penn.
Posts: 386
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I believe i have fixed my problem the hose to where the coolant leads to, the cap was loose and was leaking coolant so i took it off cleaned it because there were debris on the cap checked the coolant for any debris put it back on tightly started it up let it run for about 5 min and checked it, there was no leaks at all. Thank you guys for you're quick responses and suggestions. ,James
jballem is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Coolant leak MB-W202 W202 C-Class 14 06-04-2014 03:10 PM
    Small coolant leak- addative to help trace leak? HACK THT W163 M-Class 10 02-08-2011 04:22 PM
    Coolant leak 300E W140 S-Class 1 10-22-2010 12:59 PM
    Coolant Leak jfunk W124 E,CE,D,TD Class 0 08-24-2005 02:13 AM
    What does a coolant leak smell like with MB coolant? pcmaher W140 S-Class 3 09-27-2004 12:47 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome