Vito Speedo Problem. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-01-2011, 10:34 AM Thread Starter
BenzWorld Newbie
Date registered: Mar 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Vito Speedo Problem.

I have recently purchased a 2000 vito van and the speedo is not working and the miles are going up but really slowly. When starting up the speedo needle moves upto about 70mph and then returns to the bottom. Could it be the speed sensor or is it more likely to be the clocks themselves. All the other gauges work fine. Any help would be appreciated.
Fatmanslim0 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-01-2011, 11:13 AM
BenzWorld Elite
1984babybenz's Avatar
Date registered: Nov 2009
Vehicle: 1984 190D 2.2
Location: Silver Spring, MD
Posts: 2,458
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Try posting in this forum:
V-Class - - Mercedes-Benz Discussion Forum

More people with your type ov vehicle will be there, so you can get your questions answered faster/ more accurately.
1984babybenz is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    vito blue bulbs for speedo paul9019 V-Class 2 10-14-2010 12:12 PM
    mercedes vito 110cdi speedo problem. cabdriver Audio & Telematics Forum 0 08-17-2008 04:55 PM
    VITO Speedo Problems VitoCamperman V-Class 0 04-04-2008 05:53 AM
    vito speedo m13toe V-Class 8 07-13-2006 10:43 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome