New member looking for help - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-28-2011, 08:27 PM Thread Starter
BenzWorld Junior Member
Date registered: Feb 2011
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry New member looking for help

ok i have an 85 mercedes 200t with 4speed manual transmission and 4cyl gaz engine.
just put a new clutch and now the transmission is bad it's doing a noise that goes off when i push on the clutch pedal .
where can i get parts to rebuild this thing or a used one or if someone knows what else will fit in it? may be the 240d with 4spd manual.
the car is in really good condition and i need to fix it
may also need a starter and a front wheel bearing .

Last edited by ghazigo123; 02-28-2011 at 08:32 PM.
ghazigo123 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 02-28-2011, 09:59 PM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,065
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Welcome to Benzworld. Please complete your profile as this will help members give you the most accurate answer to your questions. Location is also important when we need to help you find parts etc. This forum is for introductions only and all questions should be posted on the appropriate sub forum for your car.

To edit your profile simply click on quick links “edit profile” (quick links is top Right of the page)

At the bottom of the page you will find forum jump, click on this and view all the available sub forums and there you will find the technical forum for your car.

For FAQ see the Benzworld help section here:
BenzWorld Help - - Mercedes-Benz Discussion Forum



"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #3 of 3 (permalink) Old 03-01-2011, 02:24 PM
BenzWorld Newbie
Date registered: Mar 2011
Vehicle: 1974 450sl V8
Location: Florida
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
New member Ray. I have a 1974 450sl that I have owned for 9months. Everything was
running fine until my radiator hose broke. I replaced the hose and then the car was
running rough and then would not start. Points were burnt so replaced points and rotor.
Point were set at 16 would run fine but after turning off ignition for 30 min. car will start
and idle rough. Cleaned plugs and checked coil. Any help would be appreciated. Thank you.
glasspack is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    New member vjjdavid General Mercedes-Benz 2 01-13-2010 07:43 AM
    Hottest SLK from a member or X-member of this forum... post them up. OJwerks R170 SLK-Class 21 01-28-2009 10:13 PM
    New Member Belstar General Mercedes-Benz 0 12-17-2008 10:47 AM
    wtf, i'm a "member" here but i'm a "senior member" at MBWorld!! asianml Off-Topic 8 11-23-2005 05:19 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome