92 500sel - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-27-2011, 08:07 AM Thread Starter
BenzWorld Junior Member
Date registered: Feb 2011
Vehicle: 1992 500sel
Location: oklahoma
Posts: 28
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
92 500sel

I replaced the alt,battery,tensioner&belt. Still have no charge to the battery.
pfisher is offline  
Sponsored Links
post #2 of 4 (permalink) Old 02-27-2011, 12:36 PM
BenzWorld Elite
1984babybenz's Avatar
Date registered: Nov 2009
Vehicle: 1984 190D 2.2
Location: Silver Spring, MD
Posts: 2,458
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Sure it's not just a bad battery?
Also, asking in the w140 forum will get more answers.
W140 S-Class - Benzworld.org - Mercedes-Benz Discussion Forum
1984babybenz is offline  
post #3 of 4 (permalink) Old 02-27-2011, 12:52 PM Thread Starter
BenzWorld Junior Member
Date registered: Feb 2011
Vehicle: 1992 500sel
Location: oklahoma
Posts: 28
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
alternator trouble

Thank you for responding. Can't get answer from other forum.
pfisher is offline  
post #4 of 4 (permalink) Old 02-28-2011, 09:14 AM
BenzWorld Elite
Date registered: Dec 2002
Vehicle: 92 500SEL to 01 E320T current 2014 lexus LS460
Location: Florida
Posts: 3,886
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
If you have done all that, have you actually put a volt meter on the battery? This might not apply but here you go. I never had a charging issue on my 92 SEL, I had my cluster rebuilt and the charge light would come on and then go away after a while, I had MB come out and checked the battery before replacing, the tech said it was fine, I replaced it anyway. A couple of weeks later same issue, I took it in new alternator, few days later light comes on intermittantly. They replaced the tensioner and belt, some weeks later same thing. The only reasoning I have is when they repaired the cluster the fault was introduced. The only common thing is that when the temperature is cold, the light comes on for a while, on warm days no issue. I have searched for loose connections, bad grounds, I can get the light to go out, when I turn on the seat heaters, and then back off. I did learn that the light will come on with under voltage or over voltage, which leads me back to the cluster.
Peter Guenther is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    m117.963(500sel before 1985) and m117.965(500sel after 1985) difference presscot W126 S,SE,SEC,SEL,SD,SDL Class 0 07-12-2010 07:14 AM
    500SEL 84 Grumbleweed W126 S,SE,SEC,SEL,SD,SDL Class 12 12-09-2008 04:29 AM
    89 500sel trans fit a 1991 500sel?? coully W140 S-Class 7 08-07-2007 01:33 AM
    help on my 500sel hcllc W140 S-Class 3 02-03-2006 11:07 AM
    Anyone need parts for a 500sel, I have 1984 500sel parting out nckmsn For Sale/Wanted/Trade/Giveaway 0 04-19-2005 02:06 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome