94 E-320 idle problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-18-2011, 03:27 PM Thread Starter
BenzWorld Newbie
 
Date registered: Feb 2011
Vehicle: 1994 E-320 Sedan
Location: San Antonio, TX
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
94 E-320 idle problem

Hi. I have a 1994 E-320 which recently started having an idle issue when at operating temp.
Quick time line: My Ce light came on about 4 weeks ago. Was told it was the upstream O2 sensor. Didn't repair immediatley. About 2 weeks into the CE light being on my engine started to have the idle problems. The idle is fine during the first 5-10 minutes of operation.
At an idle the rpms will increase to just above 1K then quickly drop below 500. This will repeat several times and if I don't start moving again the engine will eventually die.
I just replaced the O2 sensor and still having the same problem.
Any ideas would be appreciated
Thanks
jsfosdick is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-18-2011, 05:44 PM
BenzWorld Elite
 
1984babybenz's Avatar
 
Date registered: Nov 2009
Vehicle: 1984 190D 2.2
Location: Silver Spring, MD
Posts: 2,458
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Search in this forum, might have the same issue

W124 E,CE,D,TD Class - Benzworld.org - Mercedes-Benz Discussion Forum
1984babybenz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Testing Idle Valve - High Idle Problem Jonathan Laws W126 S,SE,SEC,SEL,SD,SDL Class 16 08-11-2012 05:55 AM
98 E-320 Idle speed luisv-rod W210 E-Class 1 10-31-2010 10:38 AM
Idle Problem-surging Idle-1990 560 SEC gregory113513 W126 S,SE,SEC,SEL,SD,SDL Class 3 08-14-2009 10:42 PM
ML 320 Engine Idle, please help stevhuff W163 M-Class 9 07-08-2009 07:36 AM
what degree does your 320 idle at? lowrinlife C208/A208 CLK-Class 4 03-28-2007 06:10 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome