New member from Los Angeles CA - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-22-2011, 10:01 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2011
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New member from Los Angeles CA

Hello,

I am new to this forum- I am a huge Mercedes Enthusiast. I have owned many Mercedes from C180, C240, 300E, E320, E430, S420, 600SEL, CLK430, 02 S430, CL 500 all sold. Currently I have a 04 Mercedes S430 with 89k miles that has a vibration at 60 MPH. ( I posted a question about my 04 S430 any advice on how to navigate around this forum would be much appreciated) My previous 02 S430 and 00 CL500 had the same symptoms and never did I figure it out. Any advice or suggestions would be gladly appreciated.

Last edited by Parispresto; 01-22-2011 at 10:02 PM. Reason: miles
Parispresto is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-22-2011, 10:24 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,176
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Welcome to Benzworld. Please complete your profile as this will help members give you the most accurate answer to your questions. Location is also important when we need to help you find parts etc. This forum is for introductions only and all questions should be posted on the appropriate sub forum for your car.

At the bottom of the page you will find forum jump, click on this and view all the available sub forums.

For FAQ see the Benzworld help section here:
BenzWorld Help - Benzworld.org - Mercedes-Benz Discussion Forum

Regards

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #3 of 5 (permalink) Old 01-22-2011, 11:35 PM
BenzWorld Member
 
Date registered: Jan 2011
Vehicle: BMW E36 M3, E36 328is - sold, 190e sportline LE, 190e 2.3 8v
Location: Socal
Posts: 68
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Is the vibration only at higher miles? There could be many reasons for that. How old are the tires? If they're old then that could be one reason. Another wheel balance needs to be checked. Check your tie rods, ball joints for play. I have worked on my bimmers alot and i know that these components are present on my cars but am not too familiar with the suspension setup for mercedez. I will however check these things out according to the setup. Have your wheel balance checked first.

Good luck.
190sportlineLE is offline  
post #4 of 5 (permalink) Old 01-23-2011, 08:59 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2011
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you, 190sportlineLE
Parispresto is offline  
post #5 of 5 (permalink) Old 01-23-2011, 08:09 PM
BenzWorld Member
 
Date registered: Jan 2011
Vehicle: BMW E36 M3, E36 328is - sold, 190e sportline LE, 190e 2.3 8v
Location: Socal
Posts: 68
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
You Welcome. If you want here are a few steps to check out some of the suspension components of the car.

First have your wheel balance checked out.
Then check your tires. If they're old then usually thats one of the reason since the tires are worn at a certain way and hence can create the issue that you're having.
Check your ball joints by taking a huge pliers type ranch and try to compress it. If it moves then your ball joints are bad.
grab the tire by 12 and 6 and try to see if you can pull or push the wheel. If there is any play then its the wheel bearing.
Then grab the wheel by 9 and 6 and do the same. If there is play then its your tie rods.
Check your control arm bushings to see if they have deteriorated.

If you are not comfortable with your troubleshoot outcome then have a professional check it out.

Hope this helps
190sportlineLE is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Hello from New Member in Los Angeles ferrast General Mercedes-Benz 1 01-18-2011 06:48 PM
    New Member from Los Angeles Minorl General Mercedes-Benz 1 11-19-2010 06:39 PM
    New Member in Los Angeles velocedriver General Mercedes-Benz 2 08-14-2009 10:37 AM
    New Member Los Angeles el31415 General Mercedes-Benz 2 05-25-2009 10:52 PM
    New Los Angeles Member 01 SL500 playbygolf General Mercedes-Benz 5 03-05-2009 03:56 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome