New battery put in, now dash lights not working? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-13-2011, 04:04 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post New battery put in, now dash lights not working?

I am new to the forums, so I apologize in advance if I posted this in the wrong place! I have a 2003 ML350 SUV, and during this cold storm..developed a dead battery! Had a new put in. Since I drove home today in the daylight, I didn't notice the dash lights not working. I do have the gauge turned all the way as bright as it will go. As far as the dash goes, three circles..gas, speed, temp. Only ONE is working. The only two are COMPLETELY dark. Not an ounce of light. I had never had a problem with these before, so I'm definitely assuming something with the new battery has caused it. Anyone know what I can do, if I can just fix this myself? Thank you so much!
benzml350girl is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-14-2011, 10:05 AM
BenzWorld Elite
 
mbvis's Avatar
 
Date registered: Jan 2010
Vehicle: 99 E430, 01 E430 Sport, 00 SL500
Location: LA, CA
Posts: 3,266
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
mbvis is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Dash lights not working w126 Tumbo General Mercedes-Benz 1 07-30-2014 03:56 PM
dash lights + cd deck not working stuffandthings W123 E,CE,D,CD,TD,TE Class 0 06-01-2007 07:07 PM
Dash lights not working itilfly W126 S,SE,SEC,SEL,SD,SDL Class 6 05-13-2007 07:18 PM
Dash Lights Not Working gordon scott Audio & Telematics Forum 6 12-25-2006 04:12 PM
dash lights not working FRED 524 W123 E,CE,D,CD,TD,TE Class 0 04-29-2005 10:04 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome