1996 E320 misfire problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-09-2011, 10:49 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1996 E320 misfire problems

Hello, i am new to the forum as well as the car! I was trying to sell it and when the person took it for a test drive, the check engine light came on as well as the check electronics. It started to sputter and lose power, barely made it back. It has been running like a charm. I set in it and started it and it sounded awful, and for a brief moment it said battery charging? We have cleaned the MAF and took it an auto store to find out what the codes were and they stated that it was in need of a tune up, plugs and wires. We changed out plugs, not wires yet, sounds better, but still rough. I read a post on here that said this
"today i changed the plugs to e3 spark plugs, flipped the coils and cleaned the maf with maf spray. what a huge difference!!! the car runs great!!! lets see if this was the problem and if it keeps running like a champion. my fingers are crossed.
cjshade thanks for your help!!!

What does he mean by he flipped the coils? (did he change them or move them arround etc.) I am low on money, this is why selling the car, so any advice would be appreciated.

Thanks
beamkim is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-09-2011, 12:09 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,282
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
What were the codes? He means that if there is a misfire on a specific cylinder, you can switch the ignition module with one that is on a cylinder that is not showing a misfire. If you get a misfire on the other cylinder, then there is a chance the ignition module is faulty.

Mike
Michael Pillay is offline  
post #3 of 4 (permalink) Old 01-09-2011, 12:32 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2011
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1996 E320 misfire

They told him that 1 and 2 cylinders were misfiring. When we took outno. 2 it did look burnt, but the others looked pretty good. Believe the code wasP0300. Not sure. Could the coil pack be bad on no. 2? Also, how do you switch the ignition module? (rooky question huh). Thank you for helping me.
beamkim is offline  
post #4 of 4 (permalink) Old 01-10-2011, 04:51 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,282
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
P0300 is just a random misfire. You can switch the coil packs and see it for get a misfire on another cylinder. If I remember correctly, the ignition module is just held by an internal torx screw.

Mike
Michael Pillay is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1996 E320 Misfire/Shaking! SiL3nT44 W210 E-Class 14 12-29-2013 01:42 PM
    1996 e320 waterpump problems choppere320 W210 E-Class 6 04-18-2010 11:54 AM
    2000 e320 wheels fit 1996 e320? choppere320 W210 E-Class 2 10-21-2009 01:26 PM
    ABC and misfire problems cimi_s600 W220 S-Class 0 07-22-2009 07:36 PM
    1996 E320 Idle Problems 190e_merc_boy W210 E-Class 10 05-11-2009 04:21 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome