A/C Cable and other questions - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-05-2011, 07:59 AM Thread Starter
BenzWorld Member
Date registered: Aug 2010
Vehicle: 190E 8v 2.3 Mercedes Benz Make 1987
Location: Venezuela
Posts: 51
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
A/C Cable and other questions

Hi Forum, I've a E190 year 1987 2.3. I just changed the A/C compressor and i might missed something. I would like to know if the A/C Compressor has 2 electric connections: the first one that starts the compressor and the electric fan and the second one to a switch or connection to the engine in order to put the idle speed of the car a little bit more up.

This question is because, my car when i'm driving with the ac off the rpm are ok, over the 1200 rpm. but when the ac is on, it drops below 1000, between 700 and 900 rpm.

The other question is related to the temperature. The car, also with the ac on marks a temp below 80 degrees. I think the thermostat is not working, but i would like to know which is the correct temp of this car in order to function perfectly.

If you need a photo of the piece that i talk about in the first question i would upload a photo just to see it.

Please help me,

Thanks in advance
rdiaz19 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    questions about DIY for accelerator cable, motor mounts fredvillanueva@gmail.com W201 190-Class 1 09-06-2010 09:52 PM
    1992 400E rust repair questions, and general restoration questions Zack1978 W124 E,CE,D,TD Class 6 10-04-2008 07:02 PM
    how to adjust throttle cable or the accelerator cable 300te 1992 autosleek W124 E,CE,D,TD Class 0 07-21-2008 10:01 PM
    More C230 Questions.. This Owners manual makes no sense...Lighting questions..HELP.. Blackvette W203 C-Class 3 02-19-2008 05:17 AM
    Battery cable questions Loi R170 SLK-Class 3 05-18-2006 06:17 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome