New secondary air pump burned up - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-04-2011, 07:01 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question New secondary air pump burned up

Recently replaced the secondary air pump on 1999 ML320. The old one was burned up so thought this will be an easy repair. Installed the new pump, cleared the fault code, closed the hood. Four days later the check engine light came back on. Checked the codes and sure enough "secondary air fault". Checked the fuse and yep its blown. Test the air pump motor and it was burned up. Soooo, what would cause the two pumps to burn? If the valves were not opening or the ports in the head were clogged it would seem that the fan would dead head but as it is only supposed to operate on cold start it does not seem that should overheat it to failure. Any insight will be greatly appreciated.
Dahunter is offline  
Sponsored Links
post #2 of 3 (permalink) Old 01-05-2011, 02:34 AM
BenzWorld Elite
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
have you checked the relay??? if the relay is sticking then it will cause the pump to run all the time thus overloading the pump and blowing the fuse
Streetglower is offline  
post #3 of 3 (permalink) Old 01-08-2011, 08:05 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Finally got a chance to test the relay function. It cycled on and then off at the 90 second interval as it is supposed to (my understanding anyway). Obviously, it could be sticking at some time and I will replace before trying another air pump. Both of the failed air pumps got so hot they melted the brushes out of the plastic motor housing. Voltage is okay at 14 volts. Am I missing something else????
Dahunter is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    I need help with my ML430 Air Pump Burned! KAYLASML W163 M-Class 15 03-19-2010 07:07 AM
    WHAT IS THE FUNTIONS : SECONDARY AIR PUMP SilverW220 W220 S-Class 1 06-17-2008 11:13 AM
    Servicing a Secondary Air Pump pcy W163 M-Class 1 03-30-2008 04:42 AM
    Secondary Air Pump Jeff522 W210 E-Class 0 10-14-2007 09:00 AM
    Secondary Air Pump laxman0324 W163 M-Class 3 02-26-2006 06:12 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome