Help please! C200 not starting up. - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-04-2011, 02:56 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2011
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Help please! C200 not starting up.

Hi,

Having problems with Mercedes C200. Forgive my ignorance, but I really am totally clueless.

Car does not respond at all to electronic key. There's a red light which flashes briefly when I push the buttons on the key, and I read somewhere that this indicates there's no problem with the battery (true/false?).

Anyway I called up a Mercedes dealer, and was told to try changing the battery, and if that didn't help, to arrange for the car to be sent in.

I've been checking online on how to change the key battery, but oddly enough couldn't find anything. Closest thing I got were some videos on Youtube, but my key seems to be different from the ones on there.

The keys in the videos seem to have a metal key which slides out of the electronic key, which is then used to open up the electronic key. My key doesn't have this metal bit, so I don't know how to even get the key open.

No spare key either.

The key also does not turn in the ignition. I also read somewhere that battery or not, the key should be able to turn (true/false?)

Any help is greatly appreciated! Really need the car working ASAP.

Regards
Mark
MarkLim81 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    starting problems when engine is cold c200 fjallaking W202 C-Class 32 01-14-2011 09:11 AM
    Starting cold - starting hot?? rob2218 R/C107 SL/SLC Class 13 09-06-2008 08:48 PM
    Difference C200 Evolution Coupe\C200 Sports Coupe kevinblack W203 C-Class 0 07-14-2007 04:33 AM
    Starting Problem (Back window rolls down when starting up the car) fastneutron W202 C36 AMG, C43 AMG 3 08-08-2004 11:23 AM
    anyone have starting problems? My car died twice today after starting... cgeorge430 W163 M-Class 10 08-03-2002 11:57 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome