rear speakers not working?? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-03-2011, 05:54 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
rear speakers not working??

I have a "new to me" 95 C280 and the rear door speakers are barely audible even when the head unit is directing all power towards the rear speakers? I can not hear any music coming from rear window deck speakers? I have confirmed all connections are secure to the rear window deck speakers(2 speakers and sub) and they are actually there. I also have confirmed the Boss amp is in the trunk and when I disconnect amp plug the music stops. There is also an extra plug lying beside the amp, does anyone know what this extra plug is for???

I guess my amp or head unit can be bad? How can I get my hands on the wiring diagram for that amp plug to see if I am getting music to the amp??

or how else can I determine which unit is bad ??
wylieChris is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Left channel speakers not working (also cig lighter not working) PUREFUN W126 S,SE,SEC,SEL,SD,SDL Class 8 02-08-2010 09:41 PM
    Left channel speakers not working (also cig lighter not working) PUREFUN General Mercedes-Benz 0 02-02-2010 11:56 AM
    Rear speakers not working (SLK230) bose amp fried? or maybe a fuse??? ericSLK230 Audio & Telematics Forum 4 02-03-2008 09:10 AM
    Speakers stopped working kevinhuynh87 R170 SLK-Class 3 04-10-2006 04:57 AM
    Rear speakers and CD magazine not working Guest (MBNZ) Audio & Telematics Forum 0 05-09-2002 10:10 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome