1998 E320 transmission problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-03-2011, 05:45 PM Thread Starter
BenzWorld Junior Member
Date registered: Aug 2010
Vehicle: 1998 E320
Location: Boynton Beach FL
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1998 E320 transmission problem

1998 E320 Last week, I started car; it clunked when I shifted in reverse, and clunked when i put it in forward. When I got on road, it would not shift out of low. I immediately took it back home to re assess when I had time. (Note- though I'm in Florida, the temperature went below freezing the night before)

I took it out again a few days ago, and it was fine; I've been driving it with no symptoms.

Car has 148 k miles. I'm concerned that by changing transmission fluid, I may loosen gunk and cause more problems. I was thinking that maybe, as a compromise, I could just change pan and replace filter, rather than a complete flush. Any thoughts??

What kind of fluid? Seems like half the postings on this forum say only MB fluid (there seems to be more than one type) and the other half recommend dexron 3 or 4. What about additives?

mgreenb561 is offline  
Sponsored Links
post #2 of 5 (permalink) Old 01-03-2011, 07:13 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,484
Mentioned: 9 Post(s)
Quoted: 1044 Post(s)
Your car has converter drain.
Drain it all, wipe the pan clean and refill with MB fluid. Your conductor plate might be failing. It is $140 part and can be replaced as a precaution at the time of service.
More info in DIY in W210 section.
Welcome to the forum.
Kajtek1 is online now  
post #3 of 5 (permalink) Old 01-06-2011, 08:51 AM Thread Starter
BenzWorld Junior Member
Date registered: Aug 2010
Vehicle: 1998 E320
Location: Boynton Beach FL
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
mgreenb561 is offline  
post #4 of 5 (permalink) Old 01-06-2011, 09:38 AM
BenzWorld Elite
mbvis's Avatar
Date registered: Jan 2010
Vehicle: 99 E430, 01 E430 Sport, 00 SL500
Location: LA, CA
Posts: 3,266
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Some people reported similar problems when outside temperature was cold. The transmission fluid is at least 5 times thicker at cold than at hot temperature hence the "clunk". In regard to stuck at low gear, the fix was to replace the micro switch in the gear shift module. Temporary fix was to manually shift to 1st, as the car is driven, revs/speeds up, manually shift to 2, 3, ..., D. You can't miss the shifting, thanks to the slotted rail.
mbvis is offline  
post #5 of 5 (permalink) Old 01-06-2011, 09:41 AM
BenzWorld Elite
Check Codes's Avatar
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
First thing I'd do is check for codes. If the TCM set any they most likely will have to be cleared by a shop with SDS, Snap On, etc.

The connector could also be leaking.

Read through the 722.6xx FAQ thread. It's excellent info.

Do not use any flavor of Dexron. Use only MB-spec fluid 236.10 or higher. There are affordable ones out there, like the Shell/Pennzoil 134 fluid, do a search, there are some more-recent threads about it. You can get a case around $75 shipped (need 8-9 for the pan and converter drain/fill).

Good luck.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Transmission problem ML320 1998 lb_35 W163 M-Class 4 12-26-2010 04:15 PM
    over $3,000 spent: at my wits end with 1998 E320 transmission KatNYC W210 E-Class 13 09-10-2010 04:23 PM
    1998 E320 transmission problems - Please help loyalsage W210 E-Class 22 08-15-2009 06:05 AM
    WTB w210 1998 E320 transmission 722.6 simslax For Sale/Wanted/Trade/Giveaway 1 09-06-2008 05:29 AM
    Questions on 1998-99 ML320 transmission problem autobahnNY W163 M-Class 5 07-06-2004 03:43 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome