1998 ML320 Transmission Electrical Conn Leaking - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-03-2011, 06:03 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2010
Vehicle: 1998 ML 320
Location: Jacksonville, FL
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1998 ML320 Transmission Electrical Conn Leaking

Ref. Campaign 2006020008 - Transmission Electrical Connector Leaking Oil

1998 ML320 VIN # 4JGAB54E7WA033688
Please advise - In process of replacing the transmission electrical connector parts with new purchased from locak MB Dealer. While at the dealer I checked to see if there were any outstanding recalls on my vehicle...none were found.
The connector part that goes into the transmission that is held in by the small 7mm screw, will not come out. Just turns with no release.
Please advise next step. I do not want to force the connector.
I do not have any history that the above campaign took place.
Thanks in advance for any help. :
Chopper342 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1998 ML320 Transmission Elec Conn Chopper342 General Mercedes-Benz 1 01-03-2011 09:30 PM
    Transmission problem ML320 1998 lb_35 W163 M-Class 4 12-26-2010 04:15 PM
    1998 ML320 Fuel Related Issues I think? Electrical? Please Help.... dsklav W163 M-Class 3 09-17-2009 01:10 PM
    ML320 (1998) Electrical Problems SFedyshyn General Mercedes-Benz 3 11-11-2008 10:08 PM
    Questions on 1998-99 ML320 transmission problem autobahnNY W163 M-Class 5 07-06-2004 03:43 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome