1997 C280 wouldn't start - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-02-2011, 05:58 PM Thread Starter
BenzWorld Senior Member
 
waybomb's Avatar
 
Date registered: Apr 2005
Vehicle: 2005 S55; 2003 ML350; 2002 C240; 1997 C280 Sport; 1991 300SL; 1986 190e 2.3 16V (2); 1968 W30 442
Location: South of the North Pole
Posts: 528
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
(Thread Starter)
1997 C280 wouldn't start

1997 C280 sport, 148,000 miles, owned since day one.

Been on vacation for a week. The car has sat in it's place from last Thursday, 23DEC. Wednesday this week, I started it up, moved it over one parking spot (had granite delivered and wanted to make plenty of room), and turned it off. Tonight, I went to start it up. It started, but idled real slow for a few seconds and died. Then no start, as in an older carbureted flooded carb. Kinda sputtering.

We've had some odd weather in the last week. Snow, hard rain, 10f, 50f, sunny, etc. Can't believe weather had anything to do with this - this car has been all over the country, in all types of weather.

So, I first check all the fuses - all ok. I couldn't tell if the fuel pump ran on this car; never could - it has always been unusually quiet, plus, it was very windy tonight.

Then I got some starter fluid, sprayed it in the grill intake. Kindas started, but not really.

Pulled the MAF connector off. Nothing. Reconnected

Disconnected MAF housing from intake. Sprayed starter fluid in the MAF off to the side, not on the sensor directly. Nothing Put it back together.

Unscrewed gas cap. Had a "whoosh". Started engine up after a few cranks. Ran like it had been flooded, and cleared itself very quickly.

No CEL, and runs as if nothing was wrong.

Any ideas? I'll be taking it to the local Indy for a scan.

Thanks for any ideas.

ps - posted in 202 section as well

Thanks!
Fred
2005 S55
2003 ML350
2002 C240
1997 C280 Sport
1991 300SL
1986 190e 2.3 16V (2)
1968 W30 442
1988 46' Cougar US1 with Triple blown 572s
http://s4.photobucket.com/albums/y145/waybomb/
Warming the Globe, 24 Cylinders at a Time
Point me to a 126 wagon in the States PLEASE!
waybomb is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1997 C280 wouldn't start waybomb W202 C-Class 2 01-02-2011 06:43 PM
    1997 C280 Won't start-no codes mrc280 W202 C-Class 2 11-02-2009 07:46 PM
    1997 C280 Won't start-no codes mrc280 General Mercedes-Benz 5 10-19-2009 08:17 PM
    C280 Sport - 1997 - Will not start - HELP! Big Dog General Mercedes-Benz 2 12-27-2007 04:38 PM
    Difference in feel between the 1997 C280 and 1999 C280 SechsPackSound W202 C-Class 3 04-18-2006 06:48 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome