c230 Kompressor cold no start - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-22-2010, 06:18 AM Thread Starter
BenzWorld Junior Member
Date registered: Dec 2010
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
c230 Kompressor cold no start

I,m new to this site but have a problem with really cold no starts on our 2000 C230 Kompressor. On really cold days (-10C) it turns over fine but will not start altough I do hear it maybe fire once. If you warm up the throttle body just for a couple of minutes with a hair drier it starts. I removed and cleaned the throttle plate (very dirty) but still have problems when very cold. This morning it once again did not start so I turned off the key, put the gas pedal to the floor and it started fine. In many cars, this represents a flooded condition to the computer and shuts off the fuel injectors. I have seen many threads on this site regarding no starts and am thinking of replacing the TPS and possibly the CPS. The car runs great once started..New plugs were installed recently.. No check lights are on...Thanks for any help on this problem..By the way, I am very well informed on any of the computer related input/ output components...
kompboy is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-24-2010, 05:40 AM Thread Starter
BenzWorld Junior Member
Date registered: Dec 2010
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Turned out to be the CPS (crank pos. sensor) and it was intermittent!!!
kompboy is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    C230 Kompressor won't start jceh1 W202 C-Class 12 12-26-2010 06:21 PM
    1999 C230 Kompressor Won't Start!! Help! Dayuma W202 C-Class 3 04-21-2010 05:55 PM
    2002 C230 Kompressor ESP light and no start denmaniac General Mercedes-Benz 0 03-23-2010 08:21 AM
    IS IT POSSIBLE TO PUT A COMMAND START IN A 2000 C230 KOMPRESSOR? Roger King Audio & Telematics Forum 1 08-28-2007 01:36 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome